Buscar la última fecha de un rango de datos en Excel

Hay actividades que son controladas en Excel en las que resulta relevante determinar la última fecha en que un elemento se ingresó, o mejor, encontrar la última fecha que hace referencia a un elemento o dato determinado.

Supóngase que se tiene en una hoja la lista de empleados y las fechas en que estos han sido objeto de un llamado de atención, una amonestación o cualquier otra novedad. Con seguridad en algún momento requerimos saber cuál ha sido esa última fecha en que ese empleado fue sancionado.

A manera de ejemplo tenemos la siguiente tabla:

A

B

Código empleado

Fecha novedad

1548

27/10/2012

1765

25/11/2012

4756

29/04/2012

1587

07/03/2012

1548

16/05/2012

4756

17/05/2012

4756

25/11/2012

1765

11/08/2012

1587

20/11/2012

1765

14/07/2012

Los datos están en las columnas A y B. Lo primero que haremos será extraer los códigos únicos, puesto que allí hay empleados que se repiten. Para ello consulte Crear en Excel una lista de valores únicos de una lista de valores repetidos.

Esos códigos únicos los extraemos en la auxiliar, por ejemplo la D. En la columna E colocamos la fórmula que se encargará de hallar t extraer la última fecha que afecta a cada código listado:

=SUMAPRODUCTO(MAX(($A$2:$A$100=D2)*$B$2:$B$100))

Se ha utilizado la función MAX que encuentra la máxima fecha, y la función SUMAPRODUCTO que se encarga de buscar el código asignado en la celda D2 en la matriz A2:B100 y relacionarlo con esa máxima fecha encontrada.

Para los otros códigos se arrastra la fórmula hacia abajo.

Descargar ejemplo en Excel

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

4 Opiniones
  1. ARTURO dice:

    muy buena formula me ayudaste en mucho con esto fue parte para saber el ultimo precio comprado de un catalogo de productos, no le se mucho al excel pero me ayudo y ahora actualiza mis precios en base a la ultima compra.

  2. FErnando dice:

    Como harian para que en vez de mostrarme la última fecha de registro, me mostrara la penúltima fecha regitrada.
    Gracias.

  3. benjamin dice:

    Excelente formula

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.