Comparar columnas en Excel

En ocasiones necesitamos comparar dos columnas en Excel para determinar valores coincidentes o repetidos y extraer ya sea los coincidentes o los únicos.

En este caso vamos a suponer que tenemos datos en las columnas A y B y en una tercera columna necesitamos extraer los valores que estén en la columna B y no en la A, es decir los valores únicos de la columna B.

Supongamos la siguiente tabla:

En una columna adicional necesitamos extraer los empleados que únicamente están en el centro de costos 2.

Para ello en la columna C, en la primera fila con datos colocamos la siguiente fórmula (Excel 2007 y anteriores):

=SI(ESERROR(BUSCARV(B2;A:A;1;0));B2;"")

En Excel 2010 colocamos:

=SI(ESERROR(CONSULTAV(B2;A:A;1;0));B2;"")

Seguidamente arrastramos hacia abajo para cubrir todo el rango de datos. Al finalizar tendremos la siguiente tabla:

Como se puede observar, en la tercera columna no están ni Carlos ni María, puesto que estos dos están presentes en los dos centros de costos y sólo nos interesan los empleados que pertenecen al centro de costos 2.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

Una opinión
  1. German dice:

    Hola, primero quiero felicitarlos por su excelente pagina y aprovechar para ver si me colaboran con la siguiente duda:

    A B D E
    1 Sede 01 Sede 02
    2 Periodo Valor Periodo Valor
    3 0 $ 100,00 0 $ 100,00
    4 1 $ 110,00 2 $ 120,00
    5 2 $ 120,00 4 $ 15,00
    6 3 $ 152,00 6 $ 146,00
    7 4 $ 15,00 8 $ 154,00
    8 5 $ 156,00 10 $ 258,00
    9 6 $ 146,00
    10 7 $ 1.478,00
    11 8 $ 154,00
    12 9 $ 365,00
    13 10 $ 258,00

    Tengo que comparar el valor de las columnas A (Entre A3 y A13) y D (Entre D3 y D8), si ambos datos son iguales, colocar el valor de la celda B en E, por ejemplo: el valor de la celda A3 = D3, por lo que el valor de la celda B3 se colocaría en E3, en este caso $100,00 y así sucesivamente, espero me puedan colaborar, muchas gracias.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.