Comparar columnas en Excel

Inicio » Excel para contadores. » (22 / 10 / 2011 )

En ocasiones necesitamos comparar dos columnas en Excel para determinar valores coincidentes o repetidos y extraer ya sea los coincidentes o los únicos.

En este caso vamos a suponer que tenemos datos en las columnas A y B y en una tercera columna necesitamos extraer los valores que estén en la columna B y no en la A, es decir los valores únicos de la columna B.

Supongamos la siguiente tabla:

En una columna adicional necesitamos extraer los empleados que únicamente están en el centro de costos 2.

Para ello en la columna C, en la primera fila con datos colocamos la siguiente fórmula (Excel 2007 y anteriores):

=SI(ESERROR(BUSCARV(B2;A:A;1;0));B2;"")

En Excel 2010 colocamos:

=SI(ESERROR(CONSULTAV(B2;A:A;1;0));B2;"")

Seguidamente arrastramos hacia abajo para cubrir todo el rango de datos. Al finalizar tendremos la siguiente tabla:

Como se puede observar, en la tercera columna no están ni Carlos ni María, puesto que estos dos están presentes en los dos centros de costos y sólo nos interesan los empleados que pertenecen al centro de costos 2.

Siéntase libre de opinar

27 Opiniones
  1. arturo dice:

    hola que tal tengo una duda ojala me puedan ayudar

    si yo tengo dos columnas de información una que es a y la otra b
    en la columna a tengo lo que serian códigos de producto de 5 números
    en la columna b tengo lo que seria la existencia en física de ese producto

    el problema es que tengo números los cuales repiten en la columna a con diferente existencia en la columna b

    la pregunta es como puedo hacer que la columna a se ordene y no repita códigos mientras que la b sume la existencia total de ese código

    ejemplo
    clave existencia
    a 5
    b 10
    c 5
    a 3
    a 2
    b 5
    c 10

    como resultado necesito esto

    clave existencia
    a 10
    b 15
    c 15

    por su atención gracias

  2. Hector dice:

    Hola, buenas. Tengo una consulta. Como encontrariais las coincidencias de valores entre varias columnas (más de 2, por ejemplo hasta 10 columnas). Gracias

  3. lacatira9 dice:

    Buen dia , me gustaria saber si hay una manera de conciliar dos columnas de excel tal cual se concilia un banco , me explico tengo un reporte del sistema que transfiero al programa y me ubico en mi colunmna "A" llamada "debe " y mi columna "B" llamada "haber" ambas columnas precentan cantidades numéricas referentes a pagos en bsf.
    ej:
    Debe haber
    2.910,00 13.092,13
    11.200,00 8.000.00
    1.227,24 11.200,00
    5.394,66 2.910,00
    11.200,00 1.227,24
    13.092,13 5.394,66
    5.394,66 13.092,13
    13.092,13 5000.00

    Como se visualiza hay cantidades de la columna A que se repiten en la B,(que es la idea de conciliar ya que al encontrar el par se mata uno con el otro, ) mientras otras que no ( estas cifras las necesito en un color resaltado para saber que no tienen par.) y hay cifras de igual valor, varias veces, en ambas columnas , lo cual par con par se mata, pero la cifra que se encuentre dos veces en la columna A y una sola vez en la columna B necesito que me resalte esa cifra sin par , el problema es! que como se repiten varias cifras en ambas columnas no se crear una formula simple para conciliar sin que me de error ni me deje montos por fuera ayuda por favor!

  4. Humberto Caballero dice:

    Hola, una consulta, quiero saber si se puede cotejar dos listas que contienen nombres pero no necesariamente en el mismo orden, ejemplo Caballero, Humberto vs Humberto Caballero Ureña y la única coincidencia entre ambos reportes es el número de identificación o cédula de identidad, pero incluye guiones y la formula de BuscarV sale con error #N/A.

    Se podrá cotejar con este dato que aparece mas o menos así 1-234-567 que como le dije es lo único que coincide.

    He probado reemplazando los guiones por nada quedando 1234567 pero tampoco lo relaciona con la busqueda.

    Gracias y saludos desde Panamá

  5. Silvina dice:

    Buenisimo los post.
    Les consulto a ver si se puede realizar.
    Tengo un archivo mensual q cada hoja tiene una serie de datos de clientes y sus cuotas (nombres, fecha y cuotas son las que me interesaría traer a otra hoja), a veces las cuotas son consecutivas, ejemplo: pepe 2/12 y debajo pepe 3/12.
    Al utilizar buscarv para traer las cuotas que corresponde a ese nombre solo trae la primera que figura (2/12), lo mismo con la fecha en caso que aparezca mas de una vez por mes.
    Existe una función que me deje traer tanto a la cuota 2/12 como a la 3/12 sin modificar al dato inicial que seria pepe? Por favor comenten si se entiende.
    Gracias
    esto es lo que consigo solo con buscarv
    Pepe Nelson 12/24 10/07/2014
    Pepe Nelson 17/24 13/08/2014
    Pepe Nelson 17/24 13/08/2014 la realidad es q dice en el archivo base 18/24
    Pepe Nelson 17/24 09/09/2014 la realidad que dice el archivo base es la 19/24
    Pepe Nelson 17/24 09/09/2014

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.