Inicio » Excel para contadores. » (22 / 10 / 2011 )

Comparar columnas en Excel

En ocasiones necesitamos comparar dos columnas en Excel para determinar valores coincidentes o repetidos y extraer ya sea los coincidentes o los únicos.

En este caso vamos a suponer que tenemos datos en las columnas A y B y en una tercera columna necesitamos extraer los valores que estén en la columna B y no en la A, es decir los valores únicos de la columna B.

Supongamos la siguiente tabla:

En una columna adicional necesitamos extraer los empleados que únicamente están en el centro de costos 2.

Para ello en la columna C, en la primera fila con datos colocamos la siguiente fórmula (Excel 2007 y anteriores):

=SI(ESERROR(BUSCARV(B2;A:A;1;0));B2;"")

En Excel 2010 colocamos:

=SI(ESERROR(CONSULTAV(B2;A:A;1;0));B2;"")

Seguidamente arrastramos hacia abajo para cubrir todo el rango de datos. Al finalizar tendremos la siguiente tabla:

Como se puede observar, en la tercera columna no están ni Carlos ni María, puesto que estos dos están presentes en los dos centros de costos y sólo nos interesan los empleados que pertenecen al centro de costos 2.

Opinar o comentar (Recuerda que somos de Colombia)

23 Opiniones en “Comparar columnas en Excel”
  1. Silvina dice:

    Buenisimo los post.
    Les consulto a ver si se puede realizar.
    Tengo un archivo mensual q cada hoja tiene una serie de datos de clientes y sus cuotas (nombres, fecha y cuotas son las que me interesaría traer a otra hoja), a veces las cuotas son consecutivas, ejemplo: pepe 2/12 y debajo pepe 3/12.
    Al utilizar buscarv para traer las cuotas que corresponde a ese nombre solo trae la primera que figura (2/12), lo mismo con la fecha en caso que aparezca mas de una vez por mes.
    Existe una función que me deje traer tanto a la cuota 2/12 como a la 3/12 sin modificar al dato inicial que seria pepe? Por favor comenten si se entiende.
    Gracias
    esto es lo que consigo solo con buscarv
    Pepe Nelson 12/24 10/07/2014
    Pepe Nelson 17/24 13/08/2014
    Pepe Nelson 17/24 13/08/2014 la realidad es q dice en el archivo base 18/24
    Pepe Nelson 17/24 09/09/2014 la realidad que dice el archivo base es la 19/24
    Pepe Nelson 17/24 09/09/2014

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.