Condicionando rangos en Excel

Cuanto se trabaja con Excel en ocasione es necesario condicionar diferentes rangos, de manera tal que el valor o la variable a considerar debe estar dentro de un rango definido, específico.

Los rangos pueden ser mayor a X, menor a X, mayor a X pero menor a Y, rangos que se pueden definir fácilmente con fórmulas.

Cuando el rango está condicionado a un solo límite, la fórmula es muy sencilla. Por ejemplo, si la condición para una operación es que el valor de la celda A1 sea mayor a 100, la fórmula sería:

=SI(A1>100;"X"; "")

Ahí le estamos diciendo a Excel que si A1 es mayor a 100 escriba la letra X  y si no que deje la celda vacía. Para cambiar la condición bastará con cambiar el signo > por < o por =, según se requiera.

Cuando el rango está condicionado por dos limites, la fórmula es un poco más compleja.

Supongamos que el valor de la celda A1 debe ser mayor a 500 y menor a 1.000 para que se realice determinada tarea. La fórmula sería así:

=SI(Y(A1>500;A1<1000);"A";"")

Ahora compliquemos más la situación. Supongamos que ahora necesitaremos que el valor de la celda A1 sea igual o superior a 500 e igual o inferior a 1.000. En este caso, en realidad estamos hablando de 4 condiciones, ya que debe ser igual o mayor a 500, e igual o menor 1.000. Bien, la formula sería así:

=SI(A1>=500;SI( A1<=1000;"X";""))

Con estas condicionales se pueden hacer multitud de operaciones mucho más complejas que escribir una simple X o dejar en blanco la celda; es cuestión de ser creativo según sean nuestras necesidades.

No hay que olvidar que en algunos computadores los separadores no son punto y coma, sino una coma, por lo que habrá que hacer el ajuste a las fórmulas si es que su computador opera con una coma.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

34 Opiniones
  1. david dice:

    SI LA EDAD DEL POSTULANTE ESTA ENTRE 20 Y 26 AÑOS INCLUSIVE, TIENE 2 o MAS AÑOS DE EXPERIENCIA LABORAL, ADEMAS CONOCE DE INFORMATICA, SU CONDICION SERA APROBADO EN CASO CONTRARIO NO APROBADO
    ayudenme porfa

    • Gian dice:

      Si tienes 3 columnas: 1.Edad,2.Años_de_Experiencia,3.Conoce_Informatica; creas una cuarta columna:4.Condición.
      en la cuarta columna colocas la siguiente formula:
      =SI(Y(A2>19,A21,C2="SI"),"Aprobado","Desaprobado")
      y ya está.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.