Condicionando rangos en Excel

Cuanto se trabaja con Excel en ocasione es necesario condicionar diferentes rangos, de manera tal que el valor o la variable a considerar debe estar dentro de un rango definido, específico.

Los rangos pueden ser mayor a X, menor a X, mayor a X pero menor a Y, rangos que se pueden definir fácilmente con fórmulas.

Cuando el rango está condicionado a un solo límite, la fórmula es muy sencilla. Por ejemplo, si la condición para una operación es que el valor de la celda A1 sea mayor a 100, la fórmula sería:

=SI(A1>100;"X"; "")

Ahí le estamos diciendo a Excel que si A1 es mayor a 100 escriba la letra X  y si no que deje la celda vacía. Para cambiar la condición bastará con cambiar el signo > por < o por =, según se requiera.

Cuando el rango está condicionado por dos limites, la fórmula es un poco más compleja.

Supongamos que el valor de la celda A1 debe ser mayor a 500 y menor a 1.000 para que se realice determinada tarea. La fórmula sería así:

=SI(Y(A1>500;A1<1000);"A";"")

Ahora compliquemos más la situación. Supongamos que ahora necesitaremos que el valor de la celda A1 sea igual o superior a 500 e igual o inferior a 1.000. En este caso, en realidad estamos hablando de 4 condiciones, ya que debe ser igual o mayor a 500, e igual o menor 1.000. Bien, la formula sería así:

=SI(A1>=500;SI( A1<=1000;"X";""))

Con estas condicionales se pueden hacer multitud de operaciones mucho más complejas que escribir una simple X o dejar en blanco la celda; es cuestión de ser creativo según sean nuestras necesidades.

No hay que olvidar que en algunos computadores los separadores no son punto y coma, sino una coma, por lo que habrá que hacer el ajuste a las fórmulas si es que su computador opera con una coma.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

14 Opiniones
  1. JOSE DOMINGO REYES dice:

    Buenas tardes me gustaria saber como formular esto y si se puede son un conjunto de condiciones y para cada condicion hay un valor, es la funcion si pero quisiera saber si se puede hacer =SI(K5=4;SI(K5=7;SI(K5=13;SI(K5<=22;AV14;)))))
    el valor se me da perfecto cuando es menor de 3 y entre 4 y 6 pero luego de alli me dice en los valores falso se puede hacer algo para cambiar esto?

  2. JOSÉ G. HERNNÁNDEZ dice:

    Buenas tardes.
    no se como plantear esto en formula:
    tengo cuatro columnas: 1.- salario, 2.- IVM y 3.- excedente y 4.- retención; la ecuación es así: si el salario es menor de 7000, el excedente es 0 y la retención sería 0; si el salario es mayor de 7000 y menor o igual de 18,351.78, el excedente sería salario menos IVM, aunque hayan salarios mayores de 18,351.78, ese es el techo máximo para calcular retención; en todos los casos, la retención es excedente por 0.30%.

    no se como hacer una fórmula que abarque todas estas condiciones. ayuda por favor.

  3. david dice:

    SI LA EDAD DEL POSTULANTE ESTA ENTRE 20 Y 26 AÑOS INCLUSIVE, TIENE 2 o MAS AÑOS DE EXPERIENCIA LABORAL, ADEMAS CONOCE DE INFORMATICA, SU CONDICION SERA APROBADO EN CASO CONTRARIO NO APROBADO
    ayudenme porfa

    • Gian dice:

      Si tienes 3 columnas: 1.Edad,2.Años_de_Experiencia,3.Conoce_Informatica; creas una cuarta columna:4.Condición.
      en la cuarta columna colocas la siguiente formula:
      =SI(Y(A2>19,A21,C2="SI"),"Aprobado","Desaprobado")
      y ya está.

  4. PATRICIA dice:

    Buenos días, tengo que realizar una clasificación con base en edad, para hombres y mujeres, como puedo hacer la formula?
    ejemplo:
    si tiene entre 20 y 19 años, con un resultado tengo unos rangos que me dicen si el riesgo es bajo, moderado alto o muy alto

  5. Mario dice:

    Tengo el Siguiente problema con la formula de Estimacion.Lineal
    365 7.5
    126
    371 4.1

    Como puedo le puedo hacer para que no tomo el valor en blanco y no me genere un Error.

  6. Elías dice:

    Hola, una consulta. Tengo 2 filas, una con nombres y otro con puntajes. Como los puntajes son una suma de otra hoja, van variando los numeros, y quisiera que se ordene la fila de puntajes de mayor a menor, pero no se como hacer para que las celdas de nombres correspondientes a los puntajes se ordenen de igual manera. Desde ya gracias!

  7. Mayra dice:

    Muchas gracias por la información :) la usé para condicionar valores en el cálculo de retenciones.

  8. juan manuel orrego monsalve dice:

    hola, necesito saber la formula para clasificar el resultado de una prueba de laboratorio. por ejemplo la glicemia si esta por debajo de 78 esta baja, entre en 78 - 110 esta normal y mayor a 110 esta alta. necesito saber la formula para clasificar entre alguno de los 3 valores de acuerdo al resultado de laboratorio real. por ejemplo si una persona tiene 82 de glicemia que me clasifique "Normal".

    muchas gracias.

  9. YARA dice:

    buen dia!

    necesito realizar una funcion que me indique lo siguiente

    si la celda A1 contine un indicador de 100% me de los resultados de la siguiente tabla.

    Porcentaje Color Status
    Igual a 100% Amarillo Bien
    Menor 100% Rojo Mal
    Entre 100% -114% Verde Muy Bien
    Mayor o igual a 115% Verde Excelente

  10. ALEX dice:

    LO QUE QUIERO ES Q APARESCA X CON UN VALOR Y SEPUEDE HACER LA SUMA DE VARIAS CASILLAS Y ME DE EL VALOR TOTAL DE ELLAS EJEMPO
    SI X=7 + X= 17 TOTAL X=24

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.