Contar valores diferentes en un rango en Excel

Inicio » Excel para contadores. » (12 / 06 / 2010 )

Aunque no sea muy común tener que contar cuántos valores diferentes hay en un rango de Excel, no sobra saber cómo hacerlo, en especial porque de allí se pueden derivar otras funcionalidades interesantes.

Vamos a suponer que en las columnas A y B, de las filas 1 a 10, hay una serie de valores, y queremos cuántos de ellos son diferentes.

La fórmula que debemos colocar en la celda donde queremos mostrar el resultado, es la siguiente:

Manual de Excel Avanzado. Aproveche el potencial de Excel para hacer más productivo su trabajo.

=SUMAPRODUCTO(1/CONTAR.SI(A1:B10;A1:B10))

Recomiéndanos en

Google+ Facebook Twitter
Gerencie.com en su coreo
(Gratis - Reciba diariamente nuestras novedades en su correo)

Siéntase libre de opinar

30 Opiniones
  1. Christophe dice:

    Muy útil la formula, lo que no funciona es con filtros cogiendo únicamente los valores visibles. ¿Como se podría conseguir?. Gracias

    • cinthya dice:

      Christopher si encontraste la solucion? necesito saber igual solo de los valores visibles pero me cuenta los distintos de toda la tabla, te agradeceria tu colaboracion :)

  2. RICARDO dice:

    Hola, mi pregunta es: ¿cómo puedo saber cuantos extraordinarios tiene un alumno en base a sus calificaiones? pasenme su correo y les envio el archivo para que me entiendan mejor... le agradeceria infinitamente. Gracias

    • RICARDO dice:

      Hola, mi pregunta es: ¿cómo puedo saber cuantos extraordinarios tiene un alumno en base a sus calificaiones? en el primer parcial MIGUEL en ingles tiene 7.7 y en el segundo tiene 3.2 por tanto ese no es extraordinario. En español tiene 5 y 5 ese si es extraordinario en matematicas tiene 5 y 5 por tanto esa materia tambien la tiene en extraordinario. EN CONCLUSION, MIGUEL TIENE 2 EXTRAORDINARIOS... ES ESO LO QUE QUIERO SABER... UNA FORMULA QUE SUME LOS DOS VALORES MENORES A 6 EN UNA MISMA MATERIA Y QUE EL TOTAL ME LO DE EN UNA FILA Y NO EN UNA COLUMNA...pasenme su correo y les envio el archivo para que me entiendan mejor... le agradeceria infinitamente. Gracias

      ESTA ES MI TABLA, AUNQUE LA ORIGINAL TIENE MAS DATOS

      INGLES INLGES ESPAÑOL ESPAÑOL MATE MATE ¿EXTRAORDINARIOS?
      MIGUEL 7.7 3.2 5 5 5 5 2

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.