¿Cuántas veces se repite un valor en Excel?

En algunas tareas en Excel resulta útil contar las veces que un determinado valor se repite en un rango.

Supongamos que tenemos en la columna A desde la fila 1 hasta la 500 el precio de varios productos y queremos saber cuántas veces se repite un determinado precio.

Para determinarlo haremos uso de dos funciones de Excel llamadas sumaproducto y contar.si.

La formula completa quedaría así:

=SUMAPRODUCTO(1/CONTAR.SI(A1:A500;A1:A500))

No hay que olvidar que los separadores en Excel pueden ser diferentes. En este caso se ha utilizado el punto y como (;) pero algunos computadores han sido configurados para que el separador sea una coma (,).

Con esta fórmula determinamos las veces que se repite un valor determinado. Si queremos saber cuál es ese valor que más se repite, utilizamos la función MODA.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

3 Opiniones
  1. Alex Ruiz dice:

    Excelente!! no sabia lo del punto y coma, con solo ese dato pude solucionar mi problema. muchas gracias!!

  2. Piter dice:

    Quiero contar cuantas veces ha salido el (120 o 121 o 122 ...129)
    poe ejemplo: =CONTAR.SI(A3:A200;"120;121;122;XXXXXXX)

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.