Determinar el saldo de una cuenta en Excel con sólo digitar el código

Cuando se maneja la contabilidad en Excel podemos determinar el saldo de una cuenta cualquiera con sólo digitar el código.

Una forma de hacerlo es utilizando una sencilla función BUSCARV pero en esta oportunidad lo haremos de una formas más complicada debido a la gran utilidad que representa la opción que mostraremos, toda vez que se puede utilizar en consultas más complejas que un saldo de cuenta. Se puede utilizar por ejemplo para determinar el saldo de un inventario según código y tipo de producto, etc.

Se trata de hallar  un dato utilizando dos criterios, y lo haremos utilizando de forma combinada las funciones INDICE y COINCIDIR.

Vamos a suponer que en una celda tenemos el código de la cuenta y en otra el nombre de la cuenta. El nombre de la cuenta lo llamaremos con una función BUSCARV de manera que  sólo sea necesario ingresar el código de la cuenta.

Tenemos la siguiente tabla:

código

Cuenta

Saldo

1105

Caja

10.000.000

1110

Bancos

27.500.000

1305

Clientes

78.300.000

1405

Materias primas

23.150.000

1430

Productos terminados

39.850.000

1516

Construcciones y edificaciones

98.630.000

1520

Maquinaria y equipo

53.276.000

2205

Proveedores nacionales

 4.560.000

2365

Retención en la fuente

  3.650.000

2408

Impuesto sobre las ventas

  2.860.000

3605

Utilidades del ejercicio

14.589.000

4120

Industria manufacturera

 3.569.400

5105

Gastos de personal

 9.186.500

Aparte colocamos los campos donde irá el código y la cuenta de la que queremos hallar el saldo y en una tercera celda colocamos la siguiente fórmula:

=INDICE(A2:C14;COINCIDIR(E3&F3;INDICE(A2:A14&B2:B14;0);0);3)

A2:A4  es el rango donde están todos los datos. E3&F3 son las celdas donde está el código y el nombre de la cuenta de nuestro interés.

Básicamente lo que se hace es determinar la coincidencia de E3&F3 en sus rangos respectivos  A2:A14&B2:B14.

Esta bonita fórmula es más de lo que necesitamos para determinar el saldo de una cuenta, pero de gran utilidad en otras tareas más complejas. Lo importante es saber que existe y entender la forma básica en que funciona, luego todo quedará en manos de la imaginación de cada quien.

Descargar archivo de trabajo.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.