Evitar el famoso error #¡DIV/0! en Excel

Inicio » Excel para contadores. » (04 / 01 / 2009 )

Cuando se hacen operaciones en Excel, especialmente donde es necesario dividir y alguna de las celdas está vacía o tiene un valor cero, se presenta un error muy poco estético: #¡DIV/0!

Este error se puede evitar de una forma muy sencilla, aplicando una sola condicional.

Supongamos que tenemos valores en las columnas A y B, y que debemos dividir los valores de las columnas A por los valores de la columna B.

Manual de Excel Avanzado. Aproveche el potencial de Excel para hacer más productivo su trabajo.

La fórmula para hacer esa división es básica: =A1/B1, sólo que si alguna celda de la columna B está vacía o tiene valor cero, nos presentará este feo error, así que la cambiamos por la fórmula siguiente,.
=SI(ESERROR(A1/B1);0;A1/B1)

La función ESERROR se puede aplicar a cualquier fórmula, por complicada que sea, para solventar este error.

Recomiéndanos en

Google+ Facebook Twitter
Gerencie.com en su coreo
(Gratis - Reciba diariamente nuestras novedades en su correo)

Siéntase libre de opinar

29 Opiniones
  1. Joaquin dice:

    Tengo problema en dos formulas
    =K5*100/G5
    =R5*G5/100
    los valores estan vacios o en cero
    me da este error

    #¡DIV/0!
    por favor su ayuda

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.