Evitar el famoso error #¡DIV/0! en Excel

Inicio » Excel para contadores. » (04 / 01 / 2009 )

Cuando se hacen operaciones en Excel, especialmente donde es necesario dividir y alguna de las celdas está vacía o tiene un valor cero, se presenta un error muy poco estético: #¡DIV/0!

Este error se puede evitar de una forma muy sencilla, aplicando una sola condicional.

Supongamos que tenemos valores en las columnas A y B, y que debemos dividir los valores de las columnas A por los valores de la columna B.

La fórmula para hacer esa división es básica: =A1/B1, sólo que si alguna celda de la columna B está vacía o tiene valor cero, nos presentará este feo error, así que la cambiamos por la fórmula siguiente,.
=SI(ESERROR(A1/B1);0;A1/B1)

La función ESERROR se puede aplicar a cualquier fórmula, por complicada que sea, para solventar este error.

Recomiéndanos en

Google+ Facebook Twitter
Gerencie.com en su correo
(Gratis - Reciba diariamente nuestras novedades en su correo)

Siéntase libre de opinar

41 Opiniones
  1. Daniel Paolo dice:

    Otra alternativa mejorada para la formula es la siguiente:

    Formula Inicial =SI(ESERROR(A1/B1);0;A1/B1)
    Formula Mejorada =SI(ESERROR(A1/B1);"";A1/B1)

    Donde se reemplaza el cero (0) por dos comillas (""), así el espacio nos aparece en blanco

  2. Luis Pérez dice:

    NECESITO HACER LA OPERACION

    PRODUCTO(G23:G27)

    PERO COMO LE HAGO PARA EVITAR errores tipo #!DIV/0¡. Quiero hacer el producto pero evitando que tome las celdas que contengan ese error

    Gracias

    • Daniel Paolo dice:

      Luis. Esta es una alternativa:

      Utilizar la sintaxis diferente a: ()

      Por ejemplo con esta formula:
      =SI.ERROR((PROMEDIO.SI(F9:F39;"0"));0)

      Se puede sacar el promedio de un rango (en el ejemplo F9:F39) sin tener en cuenta los ceros; ya que al especificar que es diferente a cero o en tu caso #!DIV/0, no toma éste valor.

      Espero sea de ayuda.

  3. Dav dice:

    Hola ayuda!

    Tengo que hacer un promedio de una fila con valores y errores tipo #!DIV/0¡. Quiero hacer el promedio pero evitando que tome las celdas que contengan ese error. Que no las cuente por completo.

    Intente promedio.si y en el criterio le puse #!DIV/0¡ y no funcionó.... ayuda por fa

  4. Carlos dice:

    Muchas gracias

  5. mairim guzman rodriguez dice:

    quiero dividir toda una columna por un solo numero...pero no se como alguien puede ayudarme' ejem
    litros entre 26
    360
    150
    123
    36
    569
    Asi tengo en la columna que tiene q dividirse entre ese num (26) pero no se como hacerle

  6. mairim guzman rodriguez dice:

    quiero dividir toda una columna por un solo numero...pero no se como alguien puede ayudarme' ejem
    litros entre 26
    360 ???
    150 ???
    123 ???
    36 ???
    569 ???
    Asi tengo en la columna que tiene q dividirse entre ese num (26) pero no se como hacerle

    • José dice:

      supongamos que el numero que necesitas dividir pones en una casilla x10

      y los demas numero estan en la columna A.-

      Tu formula seria

      =A1/$x$10 asi solo cambiara el valor a ser divido.- el $ es para que no sea constante esa celda.-

      espero que te sirva.-

  7. Joaquin dice:

    Tengo problema en dos formulas
    =K5*100/G5
    =R5*G5/100
    los valores estan vacios o en cero
    me da este error

    #¡DIV/0!
    por favor su ayuda

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.