Evitar el famoso error #¡DIV/0! en Excel

Cuando se hacen operaciones en Excel, especialmente donde es necesario dividir y alguna de las celdas está vacía o tiene un valor cero, se presenta un error muy poco estético: #¡DIV/0!

Este error se puede evitar de una forma muy sencilla, aplicando una sola condicional.

Supongamos que tenemos valores en las columnas A y B, y que debemos dividir los valores de las columnas A por los valores de la columna B.

La fórmula para hacer esa división es básica: =A1/B1, sólo que si alguna celda de la columna B está vacía o tiene valor cero, nos presentará este feo error, así que la cambiamos por la fórmula siguiente,.
=SI(ESERROR(A1/B1);0;A1/B1)

La función ESERROR se puede aplicar a cualquier fórmula, por complicada que sea, para solventar este error.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

22 Opiniones
  1. Carlos Roa dice:

    Porfavor alguien me puede decir, como desactivo campos o celdas en mi hoja de excel.. tengo informacion de activos y pasivos contables para tres años, quisiera entrar datos en mis celdas del primer año y que el segundo año y el tercero estuvieras desactivados, solo cuando introduzca los datos de las celdas del primer año se activen los del segundo año y luego de introducir estos se activen los del tercer año.

    Gracias
    Carlos Roa

  2. Magdalena dice:

    Hola, tengo un problema. le pido al excel una función PROMEDIO y marco las celdas que quiero pero me salta un cartel de "error de division entre cero". no entiendo por que, ya que para hacer un promedio debería dividir entre en número de datos, no entre cero...

  3. SANTIAGO CORAL CARRILLO dice:

    tENGO LA ECUACIÓN DE DISPERSIÓN DE ONDAS QUE REQUIERE ITERAR YA QUE LA CELDA ES G5 Y LA VARIABLE ESTA EN LA ECUACIÓN, SIN EMBARGO AL SER COCIENTE Y ARRANCAR LA PRIMERA ITERACIÓN QUE ES 0 ME DA ERROR DIV 0, COMO SALTAR A LA SEGUNDA ITERACIÓN 0,001 Y QUE TERMINE DE ITERAR SIN DETENERSE EN EL ERROR DE CERO; ((9,81*(C6)^2)/2*PI())*TANH(2*PI()*C5/G5))

  4. Roberto Fuentes dice:

    Hola que tal.
    Tengo un problema con la siguiente formula:

    REDONDEAR.MAS((L15-L16)/(DIAS.LAB(Reporte!$B$1;Reporte!$H$9;11);0)

    Cuando el conteo de los días laborales llega a fin de mes me sale el error : #¡DIV/0!.

    Por favor alguien que me pueda ayudar. Muchas gracias.

  5. Daniel Paolo dice:

    Otra alternativa mejorada para la formula es la siguiente:

    Formula Inicial =SI(ESERROR(A1/B1);0;A1/B1)
    Formula Mejorada =SI(ESERROR(A1/B1);"";A1/B1)

    Donde se reemplaza el cero (0) por dos comillas (""), así el espacio nos aparece en blanco

  6. Luis Pérez dice:

    NECESITO HACER LA OPERACION

    PRODUCTO(G23:G27)

    PERO COMO LE HAGO PARA EVITAR errores tipo #!DIV/0¡. Quiero hacer el producto pero evitando que tome las celdas que contengan ese error

    Gracias

    • Daniel Paolo dice:

      Luis. Esta es una alternativa:

      Utilizar la sintaxis diferente a: ()

      Por ejemplo con esta formula:
      =SI.ERROR((PROMEDIO.SI(F9:F39;"0"));0)

      Se puede sacar el promedio de un rango (en el ejemplo F9:F39) sin tener en cuenta los ceros; ya que al especificar que es diferente a cero o en tu caso #!DIV/0, no toma éste valor.

      Espero sea de ayuda.

  7. Dav dice:

    Hola ayuda!

    Tengo que hacer un promedio de una fila con valores y errores tipo #!DIV/0¡. Quiero hacer el promedio pero evitando que tome las celdas que contengan ese error. Que no las cuente por completo.

    Intente promedio.si y en el criterio le puse #!DIV/0¡ y no funcionó.... ayuda por fa

  8. Carlos dice:

    Muchas gracias

  9. mairim guzman rodriguez dice:

    quiero dividir toda una columna por un solo numero...pero no se como alguien puede ayudarme' ejem
    litros entre 26
    360
    150
    123
    36
    569
    Asi tengo en la columna que tiene q dividirse entre ese num (26) pero no se como hacerle

  10. mairim guzman rodriguez dice:

    quiero dividir toda una columna por un solo numero...pero no se como alguien puede ayudarme' ejem
    litros entre 26
    360 ???
    150 ???
    123 ???
    36 ???
    569 ???
    Asi tengo en la columna que tiene q dividirse entre ese num (26) pero no se como hacerle

    • José dice:

      supongamos que el numero que necesitas dividir pones en una casilla x10

      y los demas numero estan en la columna A.-

      Tu formula seria

      =A1/$x$10 asi solo cambiara el valor a ser divido.- el $ es para que no sea constante esa celda.-

      espero que te sirva.-

  11. Joaquin dice:

    Tengo problema en dos formulas
    =K5*100/G5
    =R5*G5/100
    los valores estan vacios o en cero
    me da este error

    #¡DIV/0!
    por favor su ayuda

  12. Yensy dice:

    Hola

    Buenas tardes pido apoyo, tengo 7 celdas con datos diferentes (1 al 12), quiero que cuando se escoja uno de estos datos me traiga varias opciones, pero cada dato viene con sus opciones, me explico: Si escojo opción 1 en otra casilla me traiga opción a, b, c, d. Si tomo opción dos me arroje otras variables, etc y pueda seleccionar alguna de estas. Cómo lo puedo hacer? qué formula empleo?

  13. victor dice:

    Requiero de su apoyo, necesito obtener el promedio de unos datos, para tal efecto como son valores Si, No y N/A, les asigné un valor mediante esta formula =SI(F13="Si",1,SI(F13="No",0,SI(F13="NA", "")))... sin embargo al promediar el resultado de los datos con la formula =PROMEDIO(O13:T13) cuando no hay un valor en las celdas me marca el error #¡DIV/0!; alguien me podria apoyar indicandome como corregir mi formula??

  14. -W- dice:

    Eh que bien. Buenísimo. Gracias.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.