Extraer el mes en texto de una fecha de Excel

Cuando en una celda de Excel se presenta una fecha del tipo 05/09/2013 podemos extraer el mes en texto, ya que  está representado en números.

Supongamos que la fecha está en la celda A2. En cualquier celda colocamos la siguiente fórmula:

=MES(A2)

Esta fórmula no extra el mes en número, que en el ejemplo es 9, pero lo necesitamos en texto, es decir Septiembre.

Una forma de hacerlo es con la función texto precisamente. Y se hace de la siguiente forma:

=TEXTO(A2;MMMM")

Si lo que se quiere convertir en texto es el día, cambiamos la M por la D y tendríamos:

=TEXTO(A2;"DDDD")

Otra forma de hacerlo es utilizando la función BUSCARV. Es un poco más compleja debido a que se necesitan datos adicionales, pero la expondremos debido a que se parecía el funcionamiento de BUSCARV que es muy útil en muchos casos.

En este caso hay que crear una columna con los números de los meses (1 a 12) y otra con los meses en texto al frente de cada número. Luego se aplica la siguiente formula:

=BUSCARV(MES(A2);E1:F12;2;0)

La fórmula se puede complicar un poco más para hacer que el texto aparezca de la siguiente forma: jueves 5 de septiembre de 2013, lo cual se logra con la siguiente fórmula:

=CONCATENAR(TEXTO(A2;"DDDD "); DIA(A2); " de ";TEXTO(A2;"MMMM");" de ";TEXTO(A2;"YYYY"))

Descargar archivo de Excel.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

2 Opiniones
  1. Dario dice:

    Excelente.
    Gracias por las fórmulas

  2. Jesus dice:

    El problema que tengo es que la fecha la tengo en ingles o en usa. Osea primero el mes y luego el dia.Como seria la formula para extraer el mes y el dia correcto?. Ejemplo 01/25/2015 seria 25 de Enero del 2015.

    Gracias

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.