Inicio » Excel para contadores. » (11 / 09 / 2012 )

Extraer texto entre paréntesis en Excel

En algún momento nos puede ser útil poder extraer el texto que se encuentre entre paréntesis en una celda de Excel, proceso que se puede automatizar con una serie de fórmulas.

Por ejemplo puede ser el caso en que encontremos lo siguiente:

Medellín (Antioquia)

Ibagué (Tolima)

Girardot (Cundinamarca)

Cali (Valle), Colombia

Quizás necesitemos extraer a una celda de Excel únicamente el nombre del departamento que se encuentra entre paréntesis.

Para ello haremos uso de la siguiente fórmula:

=SI.ERROR(EXTRAE(A1;ENCONTRAR("(";A1)+1;ENCONTRAR(")";A1)-ENCONTRAR("(";A1)-1);"")

Aquí hemos supuesto que los datos están en A1, luego si están en otra celda sólo habrá que modificarla. Luego se arrastra hacia abajo para las demás celdas.

Lo que hace esta formula es extraer lo que encuentre dentro de los paréntesis.

Si queremos extraer incluso los paréntesis, modificamos un poco la fórmula:

=SI.ERROR(EXTRAE(A1;ENCONTRAR("(";A1);ENCONTRAR(")";A1)-ENCONTRAR("(";A1)+1);"")

Nótese que hemos eliminado +1 que indica el lugar desde donde debe extraer una vez ubicado el valor referencia, en este caso el paréntesis que abre “(“, y el -1 del final lo hemos cambiado por +1 para indicar que extraiga incluso el valor referencia final encontrado “)”.

Este conjunto de fórmulas aplica para extraer cualquier criterio, no sólo valores entre paréntesis, sino valores que están después de un guion, por ejemplo, o entre comillas.

Por último, si quisiéramos extraer únicamente la primera parte, palabra o palabras, es decir, todo lo que está antes del paréntesis o el valor que le indiquemos, la fórmula será:

=SI.ERROR(IZQUIERDA(A4;ENCONTRAR("(";A4)-1);A4)

La función SI.ERROR se utiliza para cuando no haya que mostrar dentro de los criterios fijados, simplemente nos deje una celda en blanco.

Opinar o comentar (Recuerda que somos de Colombia)

3 Opiniones en “Extraer texto entre paréntesis en Excel”
  1. Nestor Pinto dice:

    Ayudaaaa por favor!! quiero extraer los nombres de celdas pero solo si cumple con una nombre que le he dado. me explico:

    En C3 TENGO TODOS LOS NOMBRES Y EN G3 TENGO UNA FORMULA DONDE me indica nombres diferentes de acuerdo a una fecha. Lo quiero entonces es que cuando en G3 tenga ese nombre que quiero automaticamente me genere el nombre que esta en la celda c3

  2. fELIPE dice:

    Estimado,

    COmo se puede separa esto 625/13/D.
    Lo que quiere es que en un celda quede 625 en otro el 13 y en otro la D.
    El problema que tengo es que esto cambio pudiendo ser 1/13/C o 111M/01/SC

  3. LEONEL dice:

    gracias por tu ayuda amigo me sirvio de mucho.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.