Mostrar en Excel la hora en que un empleado ingresa a la empresa

Excel también nos sirve para llevar el control de la hora en que ingresa o sale un trabajador de la empresa, control que se puede llevar fácilmente con una fórmula que nos permite hacer el trabajo.

Vamos a suponer que en la columna A ingresamos el nombre de los empleados de la empresa y en la columna B queremos tener la hora de entrada o salida, según sea nuestra necesidad.

Lo primero que debemos hacer es darle formato de hora a la columna B, que es la columna en la que necesitamos fijar la hora de entrada o salida del empleado. Para ello, seleccionamos la columna, damos clic con el botón derecho del mouse, y elegimos “Formato de celdas” y allí elegimos el formato de hora que más nos guste.

Ahora, en la columna B pegamos la siguiente fórmula:

=SI(A1="";"";SI(C1="";AHORA();C1))

Esta fórmula nos dará un error llamado “Referencia circular”, por lo tanto debemos habilitar el cálculo iterativo para solucionarlo [Siga el enlace para saber cómo].

Una vez habilitado el cálculo iterativo, la fórmula funcionará correctamente, y sólo bastará escribir el nombre del trabajador para que de forma automática aparezca la hora en la que se digitó el nombre.

No sobra aclarar que la hora que Excel tomará, es la hora en que se digita el nombre del trabajador en la celda, luego, si se pretende introducir los datos en una hora diferente a la que el trabajador ingresó, no servirá esta fórmula y será necesario digitar manualmente la hora.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

3 Opiniones
  1. henry alzate dice:

    cual es la formula para que excel me de el total de horas trabajadas, si el trabajador entra en la tarde y sale al dia siguiente en la mañana

  2. Daniel dice:

    EXCELENTE LA SOLUCIÓN Carlos Emiro Quintero GRACIAS POR COMPARTIR LA INFORMACIÓN SALUDOS

  3. Carlos Emiro Quintero dice:

    ENCONTRÉ LA SOLUCIÓN SIN NECESIDAD DE UTILIZAR CÓDIGOS.
    1. La fórmula propuesta en esta página es
    =SI(A1="";"";SI(C1="";AHORA();C1))
    Respecto a esto:
    a. C1 no tiene que ver nada (con esto respondo una pregunta anterior), hay que reemplazar por B1 (en la columna B es donde está la hora, es decir donde inicialmente se cambio a formato de hora)
    así la fórmula quedaría
    =SI(A1="";"";SI(B1="";AHORA();B1)) (si les presenta error, simplemente cambien el punto y coma por una coma)
    Así si da el mensaje de referencia circular, pues estamos calculado sobre la misma celda B1

    b. Tenemos que habilitar los cálculos iterativos , esto se encuentra en opciones de cálculo, o en opciones generales de excel, en la sección "Formulas", ahi habilitamos el calculo iterativo, pero lo más importante es que el número de iteraciones máximas sea 10, porque por defecto es 100
    repito: EL NUMERO DE INTERACCIONES MAXIMAS TIENE QUE SER UN VALOR DE 10.

    Y listo, se solucionan todos los problemas.
    Carlos Emiro Quintero
    Si te gustó el comentario, y te funcionó, entra a facebook a Distribuidora Pintuklar Hnos Ltda y le das ME GUSTA

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.