Inicio » Excel para contadores. » (28 / 08 / 2011 )

Separar valores negativos y positivos en Excel

Por petición de nuestros usurarios, expondremos cómo hacer para extraer o separar valores negativos y positivos en Excel.

Es posible que en una base de datos existan valores negativos y positivos, y en ocasiones podemos necesitar separarlos para una mejor identificación y análisis.

Supongamos que tenemos una serie de datos en la columna A desde la fila 2, es decir, dese A2.

Para separar los valores positivos y negativos, necesitaremos de dos columnas más, una para colocar los valores positivos y otra para colocar los valores negativos, así que las fórmulas las colocaremos en las columnas B y C.

Para separar los valores, utilizaremos la función SUMAR.SI condicionada, y la condición será que el valor buscado en el rango señalado sea negativo o positivo, o mayor o menor a cualquier otro valor, por lo que son muchas las variantes que se pueden utilizar dependiendo de las necesidades del usuario.

En este caso vamos a suponer que los valores a separar están ubicados en la columna A desde la fila 2 hasta la fila 10.000 [A1:A10000].

La formula será la siguiente:

=SI(SUMAR.SI($A$2:$A$10000;A2)>0;A2;"")

Observemos que las referencias son absolutas, por eso se encierran entre signos $, de esta forma le decimos a Excel que el rango a buscar o revisar será siempre el mismo no importa en qué celda se ubique la fórmula.

Esta fórmula la pegamos en la celda B2 o C2 y luego se arrastra hasta la última fila en que haya valores, que en este caso sería hasta la fila 10000.

La formula aquí escrita separa los valores positivos; para separar valores negativos basta con cambiar la condición, esto es cambiar >0 por <0.

Opinar o comentar (Recuerda que somos de Colombia)

10 Opiniones en “Separar valores negativos y positivos en Excel”
  1. emilio dice:

    necesito hacer esta operacion
    saldo inicial 30
    ingreso 15 45
    salida 10 35
    ingreso 5 40
    como puedo sacar las diferencias directamente sin estar haciendo operaciones uno por uno

  2. Carlos Rivera dice:

    Hola
    Estoy trabajando Microsoft office Excel 2007
    Quiero saber la formula para que de una columna de datos me sume solo los valores positivos

  3. carlos dice:

    como poner la formula ejemplo
    sumar
    a1:10
    a2: -8
    y que la formula mr de como resultado
    18
    y no. 2

  4. Pato dice:

    Hola:

    Tengo un listado de valores Entradas (+) y Salidas (-), al hacer la sumatoria, el resultado es un número postivo lo que indica que falta hacer salidas, el requerimiento es saber que valores del listado son los pendientes de dar salida, el resultado debe ser 0.

    Saludos

  5. Lidia dice:

    Necesito saber la formula para hacer una columna de redondeo, pero que puede ser negativo o positivo.
    Ejemplo $ 255.00 debe ser 255.30 en este caso se suma
    $ 285.20 debe dar 285.05 en este caso se resta
    no me acuerdo como usar la formula si gracias

  6. SARA dice:

    que tal! ayudamen por favor, como puedo hacer en excel para separar un resulta segun sea el caso positivo en un celda y si es negativo en otra, por ejemplo:

    A1= 21,000
    B1= 19,000
    RESULTADO
    D1= -2,000
    O SE ME PUEDE PRESENTAR
    A1=21,000
    B1=21,080
    RESULTADO
    C1= 80
    EL RESULTA ES POSITIVO QUE LO COLOQUE EN LA CELDA C1 Y SI ES NEGATIVO D1, OBVIAMENTE DEPENDIENTO DEL RESULTADO NECESITO QUE SE COLOQUE DE LO CONTRARIO QUE QUEDE VACIA O EN CERO

    LES AGRADECIRA MUCHO SU APOYO!!

  7. Jesus Monroy dice:

    Les comparto cuál era mi problema por si alguien lo llega a tener.

    Necesitaba sumar los valores de las celdas A y B sólo si los valores de A eran negativos.

    Simplemente necesité usar:

    =SI(A1<0, sumar(A1:B1), "")

    De esa forma sólo me sumaba los valores que necesitaba, mil gracias!!

  8. Jesus Monroy dice:

    Hey, muchísimas gracias!!! no necesitaba hacer precisamente esto...pero me ayudó bastante, es decir, la solución que necesitaba era muy sencilla (tan solo necesitaba un "SI(....)", en verdad, muchas gracias!!!