Sumar rangos de datos en Excel

En estadística, un rango de datos se entiende como aquellos valores o datos que en encuentran entre un valor máximo y uno mínimo, como por ejemplo  los datos que hay entre 20 y 50, y sobre se rango se pueden hacer operaciones en Excel, como la suma que abordaremos en esta oportunidad.

Supongamos que se realiza una campaña para conseguir recursos en pro de una obra de beneficencia y se quiere hacer un estudio para determinar según la edad, cuáles fueron los grupos que más aportaron.

Vamos a suponer la siguiente tabla de datos:

Edad

Aporte

20

10.000

21

20.000

22

40.000

23

150.00

24

40.000

25

10.000

26

70.000

27

25.000

28

30.000

Hasta 50

45.000

Para hacer las comparativas formamos grupos cada 5 años, esto es, los que tienen entre 20 y 25, los que tienen entre 26 y 30, etc.

Será necesario hacer el cálculo sólo para el primer grupo,  luego sólo habrá que cambiar el rango a la fórmula según la necesidad de los otros grupos de edades.

Las edades están en el rango A2:A32 y los aportes están en el rango B2:B32:

El primer grupo corresponde a las personas con edades de 20 años a 25 años.

Para hacer la suma de los diferentes rangos haremos uso de la función SUMA PRODUCTO de la siguiente forma:

=SUMAPRODUCTO((A2:A32>=20)*(A2:A32<=25)*(B2:B32))

Con SUMAPRODUCTO  el proceso es mucho más sencillo que si utilizamos primero condicionales como  =SI…., puesto que la misma función se encarga de encontrar la condición dada dentro de la misma fórmula sin necesidad de introducir argumentos adicionales.

En la fórmula hemos utilizado los signos >, < e =, pero dichos signos pueden ser reemplazados por una celda en donde se colores máximo y mínimos del rango y esta quedaría así:

=SUMAPRODUCTO((A2:A32>=C2)*(A2:A32<=D2)*(B2:B32))

Hemos supuesto que el valor mínimo está en C2 y el valor máximo del rango está en D2.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.