Buscar la última fecha de un rango de datos en Excel

Por

Hay actividades que son controladas en Excel en las que resulta relevante determinar la última fecha en que un elemento se ingresó, o mejor, encontrar la última fecha que hace referencia a un elemento o dato determinado.

Supóngase que se tiene en una hoja la lista de empleados y las fechas en que estos han sido objeto de un llamado de atención, una amonestación o cualquier otra novedad. Con seguridad en algún momento requerimos saber cuál ha sido esa última fecha en que ese empleado fue sancionado.

A manera de ejemplo tenemos la siguiente tabla:

A

B

Código empleado

Fecha novedad

1548

27/10/2012

1765

25/11/2012

4756

29/04/2012

1587

07/03/2012

1548

16/05/2012

4756

17/05/2012

4756

25/11/2012

1765

11/08/2012

1587

20/11/2012

1765

14/07/2012

Los datos están en las columnas A y B. Lo primero que haremos será extraer los códigos únicos, puesto que allí hay empleados que se repiten. Para ello consulte Crear en Excel una lista de valores únicos de una lista de valores repetidos.

Esos códigos únicos los extraemos en la auxiliar, por ejemplo la D. En la columna E colocamos la fórmula que se encargará de hallar t extraer la última fecha que afecta a cada código listado:

=SUMAPRODUCTO(MAX(($A$2:$A$100=D2)*$B$2:$B$100))

Se ha utilizado la función MAX que encuentra la máxima fecha, y la función SUMAPRODUCTO que se encarga de buscar el código asignado en la celda D2 en la matriz A2:B100 y relacionarlo con esa máxima fecha encontrada.

Para los otros códigos se arrastra la fórmula hacia abajo.

Descargar ejemplo en Excel

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

Una opinión
  1. apeso Dice:

    Excel formula: Buscar penúltima fecha (posición relativa variable)

    tengo este objetivo: Traer con fórmula la penúltima fecha de cada cliente:

    A B
    Fecha de compra cliente
    01/03/2018 5
    02/03/2018 7
    05/03/2018 7
    **06/03/2018 5** 'fecha objetivo
    08/03/2018 7
    **12/03/2018 7** 'fecha objetivo
    15/03/2018 5
    15/03/2018 5
    16/03/2018 7
    En otra hoja tengo el listado de clientes sin repetidos y en la columna siguiente estarían los resultados. Me enfrento con el inconveniente de que la posición relativa es variable y no me funcionaría una variante que encontré de la fórmula sumaproducto con k.esimo.mayor porque en el caso del cliente 5 sale el mismo resultado que la última fecha por estar repetido el dato, Ej:

    A B
    Etiquetas de fila Penultima Fecha
    1 00/01/1900
    4 26/03/2018
    5 15/03/2018
    6 15/03/2018
    7 12/03/2018
    En B4 tengo: =SUMAPRODUCTO(K.ESIMO.MAYOR(($A$2:$A$7231=A4)*$B$2:$B$7231;2)) Pero me lanza el 15/03/2018 y lo que se ocupa sería el 12/03/2018

    Por favor gurús, un poco de ayuda para este simple mortal. Un cordial saludo.

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.