Buscar valores en Excel con la función SUMAPRODUCTO

Las funciones BUSCAR, BUSCARV  y BUSCARH son excelentes para encontrar valores en Excel, pero en algunos casos se quedan cortas y en ese momento la función SUMAPRODUCTO resulta de gran utilidad.

La principal ventaja de utilizar la función SUMAPRODUCTO para buscar valores, es que permite buscar valores con varios criterios, algo que no se puede hace con otras funciones.

Por ejemplo, supongamos que tenemos un listado de proveedores, los productos que suministra cada proveedor  el precio de cada uno, y necesitamos buscar el valor de un producto determinado de cierta empresa.

En este caso se utilizan dos criterios para hallar el precio: empresa y producto.

Supongamos que tenemos en una columna las empresas (C), en otra los productos (D) y en otra los precios (E).

Utilizaremos la siguiente fórmula para hacer la búsqueda:

=SUMAPRODUCTO(($C$3:$C$100=G4)*($D$3:$D$100=H4)*$E$3:$E$100)

Obsérvese que  los criterios de búsqueda están fijados en G4 (empresa) y H4 (Producto). El predio lo da la formula anterior.

Si para una empresa no hay un producto, el resultado será cero.

Hemos preparado en Excel un pequeño ejemplo donde se aprecia la utilización y el fruncimiento de lo aquí expuesto.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

Una opinión
  1. CoNRaD dice:

    Excelente aporte

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.