Condicionar valores diferentes en Excel

Supongamos que partimos del valor 20 y debemos condicionar una fórmula en Excel de manera que si el valor presente en una determinada celda es diferente a 20, se ejecute o no determinado cálculo.

¿Cómo haríamos entender a Excel esa condición de si es diferente a…?

Las condiciones en Excel se pueden hacer con mayor que (>), menor que (<), menor o igual que (<=), mayor o igual que (>=) e igual (=), ¿pero cómo le decimos a Excel que no es ninguno diferente a los que yo le diga?

La forma correcta  y más corta es decirle que es diferente al valor referencia.

Si no es 20, entonces haga o no haga este cálculo, sino que coloque cero o coloque un mensaje  de error.

Formulado sería:

=SI(A1 <> 80; 0;A1*20%)

Con esa fórmula le indicamos a Excel que si el valor de A1 es diferente (no es) a 80, entonces que coloque un cero, de lo contrario, es decir, si es 80, entonces aplíquele el 20% a ese valor.

Una alternativa sería anidar las condicionales SI e Y (IF, AND) para limitar los valores mayores y menores, pero sería más complejo aunque podría ser un excelente ejercicio para trabajar nuestro sentido lógico.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.