Crear en Excel una lista de valores únicos de una lista de valores repetidos

Por

Podemos encontrarnos en Excel una lista de valores que se repiten y necesitamos extraer un elemento de cada uno, de manera que podamos crear una lista de valores únicos, que en ocasiones es necesaria para realizar otras operaciones.

Por ejemplo, es el típico caso de una lista de proveedores y precios de distintos productos. En ese caso, un mismo producto se repetirá varias veces, pero con empresas y precios diferentes, pues que diferentes empresas ofrecen el mimos producto.

Podríamos tener una lista como la siguiente:

C/F A B C
1 Empresa Producto Precio
2 E1 Tv 32P    950.000,00
3 E2 Cámara digital    380.000,00
4 E3 Dvd    120.000,00
5 E4 Cámara digital    365.000,00
6 E5 Dvd    115.000,00
7 E6 Tv 32P    980.000,00

Podría ser una lista interminable y saber cuáles son los productos únicos sería una tarea casi imposible de realizar manualmente.

Para armar la lista de productos únicos, que en este caso son tres, utilizamos la siguiente fórmula en una celda cualquiera, E2 en nuestro caso:

=SI.ERROR(INDICE($B$2:$B$100;COINCIDIR(0;INDICE(CONTAR.SI($E$1:E1;$B$2:$B$100););));"")

Luego arrastramos la fórmula hacia abajo tantas filas como necesitemos para crear nuestra lista única.

La función INDICE la aplicamos a la columna B donde están los datos que nos interese ordenar.

La columna E es donde crearemos la lista única, y empieza en E2, pero para determinar los valores únicos que hay, se parte de E1, una fila más arriba,  para evitar una referencia circular.

Aquí puede descargar un archivo en Excel con el ejemplo funcional.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.