Determinar las ventas o compras que se realizaron en un mes con Excel

Por

Utilizando Excel se puede determinar el monto de las ventas o compras realizadas en un mes cualquiera de forma sencilla, haciendo uso exclusivamente la función SUMAPRODUCTO.

Un cuadro de ventas o compras básicamente tienen la fecha de la operación, el código del producto, la cantidad de productos, el valor individual del producto y el valor total de cada operación.

Para simplificar manejaremos únicamente la siguiente tabla:

Fecha

Producto

Valor

09/05/2013

A-1001

         10.480.000

23/06/2013

A-1002

           7.800.000

04/06/2013

A-1001

           4.500.000

04/04/2013

A-1003

           3.958.000

10/04/2013

A-1004

         11.200.000

23/04/2013

A-1002

           7.400.000

19/06/2013

A-1003

           6.350.000

16/05/2013

A-1001

           5.600.000

25/04/2013

A-1002

           9.900.000

12/04/2013

A-1004

           2.830.000

Tres columnas y once filas. Por supuesto que en la realidad podemos manejar más columnas y miles de filas.

Para determinar cuántas ventas se hicieron en un mes necesitamos dos criterios:

  1. Fecha de la operación
  2. Código del producto

Con esos valores determinaremos el valor total que corresponden a esos criterios. Haremos que Excel identifique los valores que cumplen esos dos criterios y los sume.

La fórmula será la siguiente:

=SUMAPRODUCTO((MES(A2:A11)=F2)*((B2:B11)=E2)*(C2:C11))

El mes está en el rango A2:A11 y queremos buscar el mes que hemos seleccionado en F2.

El código del producto está en el rango B2:B11, y el código que  nos interesa se ha definido en E2.

Los valores que se deben sumar una vez cumplan los dos criterios asignados están en el rango C2:C11.

Nota: En la celda donde se coloca el mes que nos interesa conocer, se escribe simplemente el número del mes, para que Excel lo extraiga de la fecha completa que está en formato día, mes, año (01/04/2013).

Sencillo realmente. Aquí un ejemplo.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

Una opinión
  1. jhon Dice:

    buenas tardes
    deseo que me ayuden con la siguiente pregunta tengo la siguiente lista
    2000027642 (en blanco)

    2000029542 19-may
    2000029542 26-may
    2000029545 09-may
    2000029546 15-may
    2000029546 19-may
    2000029546 24-may

    en la cual como pueden ver tengo los mismos codigos con diferentes fechas pero debo pasar esta información de la siguiente manera

    2000027642 (en blanco)
    2000029542 19-may 26-may
    2000029545 09-may
    2000029546 15-may 19-may 24-may
    las fechas debo pasa filas es un base demasiado grande no deben quedar vacíos y si lo realizo manual, tomara mucho tiempo como debo hacer esto si hay solución posible en exel

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.