Función SUMAPRODUCTO de Excel

La función SUMAPRODUCTO permite sumar varios componentes de una matriz previamente identificados y multiplicados, o dicho de otra forma, permite multiplicar rangos de una base de datos y luego sumar su resultado según los criterios asignados.

En su manera sencilla, esta función se puede aplicar de la siguiente manera.

Supongamos que necesitamos averiguar cuáles fueron las ventas de un producto X en un mes determinado conociendo el precio de los productos y el número de productos vendidos.

Tenemos la siguiente tabla o base de datos en el rango A1:D13

F/C A B C D
1 Producto Mes Valor unitario Unidades venidas
2 A Enero                  5,000                                20
3 B Febrero                  6,000                                25
4 C Marzo                  4,000                                30
5 A Enero                  4,500                                40
6 B Febrero                  5,800                                60
7 C Marzo                  3,900                                30
8 A Enero                  5,100                                20
9 B Febrero                  6,050                                50
10 C Marzo                  4,080                                30
11 A Enero                  5,200                                18
12 B Febrero                  5,900                                40
13 C Marzo                  4,035                                60

Se trata de una lista de tres productos vendidos en el primer trimestre.

Necesitamos ahora saber cuánto sumaron las ventas de uno de esos productos en un mes cualquiera del primer trimestre. Supongamos el producto B en el mes de Febrero

=SUMAPRODUCTO((A2:A13="B")*(B2:B13="Febrero")*(C2:C13)*(D2:D13))

La formula hace lo siguiente:

  1. Busca los productos B que hay en el rengo A2:A13
  2. Busca el mes de Febrero que hay en el rango B2:B13
  3. Toma los valores coincidentes o correspondiente  a los criterios 1 y 2, busca su valor correspondiente en el rango C2:C3 (valor del producto), y luego lo multiplica por los valores correspondientes a los rangos D2:D13 (cantidades vendidas) y suma los resultados, que para el ejemplo será 1,036,500.

En lugar de escribir en la fórmula los criterios producto y mes, podemos llamarlos desde una celda. Suponiendo que el criterio producto esté en la celda F3 y el criterio mes esté en la celda G3, la formula quedaría de la siguiente forma:

=SUMAPRODUCTO((A2:A13=F3)*(B2:B13=G3)*(C2:C13)*(D2:D13))

Descargar ejemplo en Excel con la función SUMAPRODUCTO.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.