Llamar el último registro de una base de datos en Excel

Por

En algunos casos seguramente habremos necesitado llamar  o extraer el último registro o valor de una base de datos en Excel, algo que se puede hacer de forma relativamente sencilla con utilización de fórmulas.

Esto puede resultar útil, por ejemplo para llamar el saldo de una cuenta, o el saldo que adeuda un cliente, saldo que es cambiante, lo mismo que su rango en vista a que se le puedan agregar nuevos valores (abonos, pagos, etc.), desplazando hacia abajo el nuevo saldo.

Supongamos que en la columna C tenemos el saldo de la cuenta caja, y necesitamos extraer su saldo actual, esto es, el último valor resultante después de haber agregado entradas y salidas.

Para ello utilizamos la función INDICE junto con la función CONTAR de la siguiente forma:

=INDICE(B2:B500;CONTAR(B2:B500))

Estamos suponiendo que los saldos del libro de caja estarán en la columna B desde la fila 2 hasta la 500. Podrá estar en cualquiera de las filas. Un momento podrá estar en B100 y luego, después de agregarle nuevos datos de entrada y salida, el saldo del libro caja se desplazará unas filas abajo, pero ello no importa, pues nuestra fórmula traerá el último valor encontrado en el rango que le hayamos indicado.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

2 Opiniones
  1. liliana L. Dice:

    Para valores NO numéricos es mejor utilizar CONTARA en lugar de CONTAR.

    Responder
  2. joan Dice:

    se agradece

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.