Agregar dígitos o caracteres a celdas en Excel

Inicio » Excel para contadores. » (27 / 08 / 2013 )

Hace unos días explicábamos como extraer dígitos en Excel, hoy trataremos como agregar una determinada cantidad de dígitos o caracteres a una celda de Excel de forma automatizada.

Esta posibilidad es muy útil cuando necesitamos agregar a una base de datos uno o varios ceros, o algún digito o código de verificación.

Para ello haremos uso de la función CONCATENAR

La función concatenar, además de unir el texto de dos o más celdas, nos permite agregar texto o caracteres a una celda especifica desde la misa formula.

En este caso, partimos de la celda que contiene el valor inicial, y en una segunda celda colocamos la función que contiene y agregara el texto requerido.

Por ejemplo supongamos que en la celda A2 tenemos el valor 152356 y queremos agregarle dos ceros.

En la celda B2  o donde necesitemos colocar el nuevo valor, escribimos la siguiente fórmula:

=CONCATENAR(A2;"00")

Nótese que el texto o valor que se agrega, está entre comillas. Si queremos agregar el nuevo valor al inicio de la celda, la formula será:

=CONCATENAR("00";A2)

Ahora, es posible que tengamos diferente cantidad de dígitos en la celdas y necesitemos que todas las celdas tengan un determinado número de dígitos, de modo que a unas celdas habrá que agrega un dígito, a otras dos, etc.

Supongamos que necesitamos que todas las celdas tengan 5 dígitos, y algunas tienen 3, otras 4 y algunas 5.

Para solucionar esto, haremos uso de tres funciones diferentes: LARGO, CONCATENAR y la función SI.

=SI(LARGO(A2)=3;CONCATENAR(A2;"00");SI(LARGO(A2)=4;CONCATENAR(A2;"0");A2))

En este caso hemos supuesto la necesidad de agregar uno o dos ceros hasta completar 5 dígitos en cada celda.

En el ejemplo, la función LARGO  encarga de contar el número de dígitos que contiene la celda, la función SI se encarga de condicionar el contenido de la celda y la función CONCATENAR se encarga de unir o agregar los textos si la condición evaluada por la función SI se cumple.

Temas relacionados

Siéntase libre de opinar


48 Opiniones
  1. Uri dice:

    Buen día, yo quisiera saber cómo hacer para que cuando copie un número a otra celda se enteponga la letra 'P' de manera automática. Agradecería inmensamente.

  2. Miriam dice:

    como hago para que un texto como un apellido en una celda le agregue 40 caracteres en el total, y encadenarlo con la función concatenar, para tomarlo en un bloc de notas
    ayuda!!

  3. marina linares dice:

    Necesito tomar un texto de una celda, y encadenarlo con la funcion concatenar, pero completar 60 espacios o caracteres para tomarlo en un bloc de notas y me tome los 60 caracteres; lo hago con texto(A2,"00000 y cuento 60 ceros) pero no me completa cuando lo aplico, porque puede ser?

    • Cindy dice:

      Hola que tal, como estas amigo he revisado, el problema que planteas, solo me quedo la duda de con que caracteres te gustaría completar los 60, si con números o espacios.
      Pero a continuación te dejo una formula que en algún momento te podría ayudar.
      Supongamos que en la celda D14 tenemos los siguientes caracteres de texto ADFGH y que deseamos completar con la letra A a la derecha hasta que se completen 60 caracteres en total, para ello podríamos usar la siguiente formula:

      =SI(LARGO(D13)=60;D13;CONCATENAR(REPETIR("A";(60-LARGO(D13)));D13))

      Lo cual nos arrojaría el siguiente resultado:
      AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAADFGH

      Si le aplicas la función largo a la celda en donde está este resultado LARGO(D14) te saldrá 40, esta formula funciona tanto para texto como para números, tu puedes modificarla de acuerdo al número de caracteres que desees completar, para números quedaría sería:
      Supongamos que en la celda D4 tenemos el número 45789 y asimismo deseamos completar 60 caracteres en total y queremos completar con ceros los números faltantes hasta completar 60, podríamos usar la siguiente fórmula:
      =SI(LARGO(D4)>=60;D4;CONCATENAR(D4;REPETIR("0";(60-LARGO(D4)))))

      Nos daría como resultado=
      457890000000000000000000000000000000000000000000000000000000

      De este modo comprobamos que sirve tanto para texto como para números.
      También puedes agregar los caracteres que desees a la izquierda, en este caso si deseamos al número 45789 agregarles ceros a la izquierda hasta que se complete 60 caracteres, deberíamos usar la siguiente fórmula:
      =SI(LARGO(D12)>=60;D12;CONCATENAR(REPETIR("0";(60-LARGO(D12)));D12))

      Resultado:
      000000000000000000000000000000000000000000000000000000045789

      Con la fórmula repetir eliges que textos o caracteres deseas que se repitan para completar los 60.
      Espero que esto te haya sido de gran ayuda,
      Saludos cordiales =)

      • Cindy dice:

        Disculpa arriba me equivoqué te pasé el resultado de una celda D13 En donde agrego los caracteres a la izquierda, para la celda D14 la formula y el resultado sería el siguiente:

        =SI(LARGO(D14)=60;D14;CONCATENAR(D14;REPETIR("A";(60-LARGO(D14)))))
        Resultado:
        ADFGHAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

  4. Daniel Garma C. dice:

    Hola!
    Tenia el problema de agregar o eliminar ceros y visitando este foro pude solucionar mi problema, sin embargo me tope con algunas complicaciones que me gustaria aclarar para los futuros visitantes de la página.

    en el comando que se muestra en el encabezado:

    =SI(LARGO(A2)=3;CONCATENAR(A2;"00");SI(LARGO(A2)=4;CONCATENAR(A2;"0");A2))

    No me funciono en la versión 2010 salvo que solo corregi los (;) por (,) quedando de la siguiente forma:

    =SI(LARGO(A2)=3,CONCATENAR(A2;"00"),SI(LARGO(A2)=4,CONCATENAR(A2;"0"),A2))

    Muy bien explicado, gracias! por la información.

  5. lezileth dice:

    Alguien puede explicarme que es COTENAR?? y como se hace???

    Muchas gracias!!

    • Jonathan dice:

      Hola Lezileth,

      Concatenar es unir dos valores de dos celdas diferentes en una sola es decir:

      en A1 tienes JONATHAN y B1 tienes RAMIREZ en C1 pones concatenar y como resultado te da JONATHANRAMIREZ.

      Espero que te haya aclarado el uso de esta función.

      Saludos,

  6. José Luis dice:

    Como puedo formatear la celda que separe cada dos digitos con ":" con datos en hexadecimal como d022be130401 a que quede d0:22:be:13:04:01 ?

  7. FERNANDO dice:

    hola necesito hacer que en una operacion de cotenar me aparezca dos textos en una celda, eso me salio bien pero necesito que uno de los textos tenga un carácter a lado y lado
    ejm =CONCATENAR(C1;" ";A1) pero necesito ponerle a A1 como [A1]

    • Cindy dice:

      Hola Fernando como estas, he revisado tu solicitud y a continuación te detallo una solución a tu inquietud.
      Supongamos que tenemos en la celda B2 el texto 1, y en la celda C2 el texto 2 que deseas unir, para agregarle al texto 1 los [], puedes usar la siguiente formula: =CONCATENAR("[";B2;"]";" ";C2)
      siempre que desees ingresar un simbolo, corchete o texto, hazlo entre comillas, y ahi la formula concatenar lo toma como un texto más.

      Espero haberte ayudado,
      Saludos

  8. Oscar Eduardo dice:

    Me funciono de maravilla!!

    Gracias!!!

  9. Jacky dice:

    como agrego un numero intermedio x ejemplo 042355838 --(04355838 en esta como hago la formula)

  10. yuri dice:

    necesito una función que al sumar dos dígitos de diferentes celdas me de un solo dígito como resultado.

  11. Silvia dice:

    Hola, aplique la formula concatenar y funciono de maravilla!!! gracias. Pero necesito que aparezca el valor en esa celda en lugar de la formula. Como hago? Gracias nuevamente

  12. luis dice:

    Tengo numeros de celular en las celdas y necesito agregar el valor 52 a todas ellas, se puede agregar el valor a todas con una sola formula o de manera rapida?

  13. Odilie dice:

    tengo 8106118 y quiero que pase a ser 81-06-118. Cómo hago? Me pueden ayudar?

    • Betosancas dice:

      Clic derecho sobre la celda
      Seleccionas Formato de celdas
      Selecciona la etiqueta numero
      Clic en personalizado
      selecciona 0
      Clic en tipo:
      Escribe 00-00-000
      Aceptar
      Feliz tarde Odilie espero te sirva.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.