Agregar dígitos o caracteres a celdas en Excel

Compártalo en Facebook Compártalo en Twitter

Hace unos días explicábamos como extraer dígitos en Excel, hoy trataremos como agregar una determinada cantidad de dígitos o caracteres a una celda de Excel de forma automatizada.

Esta posibilidad es muy útil cuando necesitamos agregar a una base de datos uno o varios ceros, o algún digito o código de verificación.

Para ello haremos uso de la función CONCATENAR

La función concatenar, además de unir el texto de dos o más celdas, nos permite agregar texto o caracteres a una celda especifica desde la misa formula.

En este caso, partimos de la celda que contiene el valor inicial, y en una segunda celda colocamos la función que contiene y agregara el texto requerido.

Por ejemplo supongamos que en la celda A2 tenemos el valor 152356 y queremos agregarle dos ceros.

En la celda B2  o donde necesitemos colocar el nuevo valor, escribimos la siguiente fórmula:

=CONCATENAR(A2;"00")

Nótese que el texto o valor que se agrega, está entre comillas. Si queremos agregar el nuevo valor al inicio de la celda, la formula será:

=CONCATENAR("00";A2)

Ahora, es posible que tengamos diferente cantidad de dígitos en la celdas y necesitemos que todas las celdas tengan un determinado número de dígitos, de modo que a unas celdas habrá que agrega un dígito, a otras dos, etc.

Supongamos que necesitamos que todas las celdas tengan 5 dígitos, y algunas tienen 3, otras 4 y algunas 5.

Para solucionar esto, haremos uso de tres funciones diferentes: LARGO, CONCATENAR y la función SI.

=SI(LARGO(A2)=3;CONCATENAR(A2;"00");SI(LARGO(A2)=4;CONCATENAR(A2;"0");A2))

En este caso hemos supuesto la necesidad de agregar uno o dos ceros hasta completar 5 dígitos en cada celda.

En el ejemplo, la función LARGO  encarga de contar el número de dígitos que contiene la celda, la función SI se encarga de condicionar el contenido de la celda y la función CONCATENAR se encarga de unir o agregar los textos si la condición evaluada por la función SI se cumple.

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

8 Opiniones
  1. Ángeles Dice:

    Muchísimas gracias, me han ayudado bastante!

    Responder
  2. Gerardo Urbina Dice:

    Hola solicito su ayuda, tengo un archivo plano de un sistema que me da una nomemclatura de 10 digitos por ejemplo: 6204620000, pero para subir la informacion a otro sistema de costos debo agregarlo en el siguiente formato 62.04.62.00.00 como hago para insertar un “.” (punto) entre cada dos cifras. muchas gracias.

    Responder
  3. andrea Dice:

    como le hago para cambiar un numero previo al año, o sea tengo una numeración en la sumatoria se añada al numero previo. es decir tengo un dato así DTT/01/2020, y una fórmula para replicar y que el consecutivo sea DTT/02/2020.

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.

Propiedad horizontal