Encontrar el valor que más se repite en un rango de datos en Excel

Excel nos permite además de calcular datos a gran velocidad, nos permite buscar entre dentro de un rango de datos, determinados valores según las condiciones y necesidades del usuario de la información.

Esta vez trataremos de encontrar dentro de un rango de valores, el número que más se repite.

En ocasiones podemos tener una enorme lista de datos y necesitamos saber cuál de todos es el que más se repite, como por ejemplo de una lista de empleados, cuales son los empleados que ingresaron en la misma fecha, o que cumplen años en la misma fecha, o cual de todos los clientes es el que obtenido mayor descuento, etc.

En estadística existe una función denominada MODA que corresponde al valor que más se repite en una distribución o rango de datos.

Pues bien, en Excel existe la función MODA que nos permite calcular ese dato, valor o número que más se repite en un rango.

Formula

En la celda donde queremos insertar el resultado [Supongamos la B1], colocamos la siguiente fórmula:
=MODA(A1:A500)
Hemos supuesto un rango de datos en la columna A, desde la celda 1 hasta la 500.

Con esto hemos identificado cual es el valor que más se repite, pero nos falta saber cuántas veces se repite.

La función MODA nos muestra cual es el valor que más se repite, pero no nos dice cuantas veces se repite.

Para saber cuántas veces se repite un número o valor, utilizamos la función CONTAR.SI

Luego en otra celda, supongamos la C1, colocaremos la siguiente fórmula:

=CONTAR.SI(A1:A500;B1))

Nótese que estamos utilizando el mismo rango que utilizamos para calcular la moda [obviamente]. Recordemos que B1 es la celda en la que se encuentra el resultado de la MODA, es decir, allí se encuentra el valor más repetido, por tanto, lo que hace la función CONTAR.SI es contar cuantas veces se repite el numero existente en B1 dentro del rango A1:A500.

Una forma de saber directamente cuántas veces se repite el número más repetido en un rango es utilizar la siguiente fórmula:

=CONTAR.SI(A1:A500;MODA(A1:A10))

Aquí hemos anidado dos funciones, el problema es que esta fórmula nos calcula cuantas veces se repite el número más repetido, pero no nos muestra cual es ese número, por lo que necesariamente se requiere realizar los dos pasos: 1 determinar la MODA 2: Contar cuantas veces se repite el valor más repetido [MODA]

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

2 Opiniones
  1. vero dice:

    Buen dia espero me puedan ayudar

    tengo 2 tablas la primera capturo los proyectos con un numero de id en la segunda capturo el id del proyecto mas id de la tarea a realizar de dicho proyecto mi tabla esta asi
    tabla 1
    id-proyecto|fecha recibo|fecha-entrega
    1 |25-09-15 |fecha-fin tabla2

    tabla2
    id-proyecto|#tarea|fecha-inicio|fecha-fin
    1 |1-01 |25/09/15 |30/11/15
    1 |1-02 |25/09/15 |1/01/15
    problematica
    necesito que la fecha maxima de campo fecha-fin de la tabla2 sea mi fecha-entrega de la tabla1, siempre y cuando el id-proyecto sea igual

    hice la siguiente funcion pero no me funciono ya que siempre toma el valor de la ultima celda como maximo
    =MAX(VLOOKUP(Proyectos!A85,Table3,4,TRUE))

  2. Yeni dice:

    Muchas Gracias. de gran ayuda.

    Saludos,

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.