Inicio » Excel para contadores. » (07 / 09 / 2008 )

Encontrar el valor que más se repite en un rango de datos en Excel

Excel nos permite además de calcular datos a gran velocidad, nos permite buscar entre dentro de un rango de datos, determinados valores según las condiciones y necesidades del usuario de la información.

Esta vez trataremos de encontrar dentro de un rango de valores, el número que más se repite.

En ocasiones podemos tener una enorme lista de datos y necesitamos saber cuál de todos es el que más se repite, como por ejemplo de una lista de empleados, cuales son los empleados que ingresaron en la misma fecha, o que cumplen años en la misma fecha, o cual de todos los clientes es el que obtenido mayor descuento, etc.

En estadística existe una función denominada MODA que corresponde al valor que más se repite en una distribución o rango de datos.

Pues bien, en Excel existe la función MODA que nos permite calcular ese dato, valor o número que más se repite en un rango.

Formula

En la celda donde queremos insertar el resultado [Supongamos la B1], colocamos la siguiente fórmula:
=MODA(A1:A500)
Hemos supuesto un rango de datos en la columna A, desde la celda 1 hasta la 500.

Con esto hemos identificado cual es el valor que más se repite, pero nos falta saber cuántas veces se repite.

La función MODA nos muestra cual es el valor que más se repite, pero no nos dice cuantas veces se repite.

Para saber cuántas veces se repite un número o valor, utilizamos la función CONTAR.SI

Luego en otra celda, supongamos la C1, colocaremos la siguiente fórmula:

=CONTAR.SI(A1:A500;B1))

Nótese que estamos utilizando el mismo rango que utilizamos para calcular la moda [obviamente]. Recordemos que B1 es la celda en la que se encuentra el resultado de la MODA, es decir, allí se encuentra el valor más repetido, por tanto, lo que hace la función CONTAR.SI es contar cuantas veces se repite el numero existente en B1 dentro del rango A1:A500.

Una forma de saber directamente cuántas veces se repite el número más repetido en un rango es utilizar la siguiente fórmula:

=CONTAR.SI(A1:A500;MODA(A1:A10))

Aquí hemos anidado dos funciones, el problema es que esta fórmula nos calcula cuantas veces se repite el número más repetido, pero no nos muestra cual es ese número, por lo que necesariamente se requiere realizar los dos pasos: 1 determinar la MODA 2: Contar cuantas veces se repite el valor más repetido [MODA]

Temas relacionados

Opinar o comentar (Recuerda que somos de Colombia)

12 Opiniones en “Encontrar el valor que más se repite en un rango de datos en Excel”
  1. Yeni dice:

    Muchas Gracias. de gran ayuda.

    Saludos,

  2. susi dice:

    Tengo este ejemplo a ver quien me puede ayudar
    tabla 1
    datos accion
    xxx realizar rojo
    yyy realizar negro
    xx realizar amarillo
    tabla 2
    me salen estos datos, y me tiene que avisar que cuando me salga algun dato de la tabla 1 , es decir, 3 x o y seguidas o 2 x seguidas me avise
    xyxyxx----dos x seguidas me avise y me ponga realizar amarillo
    xyyy---tres x seguidas me avise realizar negro
    xyxyyxyxxx---lo mismo
    no siempre saldran en el mismo orden

    gracias

  3. Oscar Criollo dice:

    tengo una lista de nombres y quisiera una formula que me identifique los nombres que mas se repiten y las veces que se repite

  4. Diogenes Beltran dice:

    tengo una columna con 100 datos, algunos se repiten. necesito saber cual es el que mas se repite y cuantas veces; luego el segundo, el tercero y asi suscesivamente.

  5. Juan dice:

    Cómo se cualcula el segundo valor más repetido?

  6. carmen100 dice:

    Mi pregunta es si se puede calcular la 2 moda, es decir el valor que se repite en 2 puesto

  7. Alejandra dice:

    Hola, quisiera saber como le hago, si la moda es el numero que se repite mas veces y en los datos que tengo hay varios que se repiten el igual numero de veces
    Gracias

  8. Eliezer dice:

    Y si lo que quiero saber es cuantas veces se repite un texto, ejemplo: rojo, azul, rojo, verde.. y quiero que me devuelva rojo.. ?

  9. xiomy dice:

    chebre,super bien

  10. Jose dice:

    Excelente, el mejor, pero por ejemplo si quisiera hallar el segundo numero qu emas se repite, como se podria hacer??

  11. ROBERT dice:

    ESTA BIEN PERO EXISTE UN PROBLEMA. AL BUSCAR CUAL ES EL NUMERO QUE MAS SE REPITE EN UNA LISTA EN LA QUE LAS COMBIANACIONES SON DE 7 NUMEROS DEL 1 AL 56 ME DICE QUE EL QUE MAS SE REPITE ES EL 1 PERO CUENTA NO SOLO EL NUMERO UNO COMO TAL, SI NO QUE INCLUYE EL 10 , 11 ,12, 13, 14, 15, 16, 17, 18, ETC… COMO LE HAGO PARA BUSCAR EL 1 SOLO O EL 22 SIN QUE CUENTE EL 12, 2, 32, 42, ETC…

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.