Buscar cuántas veces se repite un valor en Excel

En algunas tareas en Excel resulta útil contar las veces que un determinado valor se repite en un rango determinado, o cuantos valores repetidos hay, lo que es fácil con la función Contar combinada con Sumaproducto.

Cuantas veces se repite un numero en Excel

Supongamos que tenemos en la columna A desde la fila 1 hasta la 500 el precio de varios productos y queremos saber cuántas veces se repite el precio 50.

Para determinarlo utilizamos la función CONTAR.SI de la siguiente forma:

=CONTAR.SI(A1:A500; "4")

Entre comillas se coloca el número que necesitamos saber cuántas veces aparece en el rango de datos.

Con esta fórmula determinamos las veces que se repite un valor determinado. Si queremos saber cuál es ese valor que más se repite, utilizamos la función MODA.

Buscar cuántos valores repetidos hay en Excel.

Supongamos ahora que debemos saber cuántos números se repiten en un rango determinado.

Con la prima fórmula podemos averiguar cuántas veces se repite un valor X, y ahora lo que necesitamos saber es cuántos valores repetidos tenemos.

Para ello utilizamos la siguiente fórmula:

=SUMAPRODUCTO(1/CONTAR.SI(A1:A500;A1:A500))

No hay que olvidar que los separadores en Excel pueden ser diferentes. En este caso se ha utilizado el punto y como (;) pero algunos computadores han sido configurados para que el separador sea una coma (,).

Guía Laboral 2024

Conozca sus derechos y obligaciones laborales como trabajador o como empleador, y evítese problemas. Ver más.

Forma de citar este artículo (APA):

Gerencie.com. (2010, septiembre 8). Buscar cuántas veces se repite un valor en Excel [Entrada de blog]. Recuperado de https://www.gerencie.com/cuantas-veces-se-repite-un-valor-en-excel.html

Recomendados.

Deje su opinión o su pregunta.
Trataremos de darle respuesta.

Regístrese para informarle cuando se responda su pregunta.

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.