Restar fechas en Excel

Restar fechas es Excel es un proceso más o menos complicado dependiendo de cómo se quiere mostrar el resultado de la resta.

La forma más sencilla de restar fechas, es una simple resta de celdas: A1-B1.

Para restar celdas se necesita que las celdas que contienen las fechas, estén en formato fecha. Para ello ubíquese sobre las celdas respectivas, de clic derecho con el ratón, y en el menú contextual que aparece, elija “Formato de celdas

Si utilizamos una simple resta, Excel nos devuelve el resultado en días. Supongamos que en A1 tenemos 25/08/2008 y en B1 tenemos 20/04/2008. Al hacer la resta A2-B2 tendremos como resultado 127 días. En este caso para que el resultado nos dé en número de días, la celda que contiene la fórmula debe tener formato número.

Si queremos que el resultado de la resta nos dé meses o años, utilizaremos la función SIFECHA, cuya sintaxis es la siguiente:

=SIFECHA(Fecha-mas-antigua,Fecha-mas-reciente,"intervalo")

El primer criterio es la fecha más antigua, el segundo criterio es la fecha más reciente y el intervalo corresponde al día, mes o año, según se requiera.

Supongamos que en la celda A1 tenemos 10/01/2007 y en la celda B1 tenemos 26/09/2008. Si queremos que el resultado de la resta nos dé en meses, la fórmula será:

=SIFECHA(A1;B1;"M")

Si queremos que el resultado nos dé en años, la fórmula será:

=SIFECHA(A1;B1;"Y")

Si queremos el resultado en días, la fórmula será:

=SIFECHA(A1;B1;"D")

Hasta aquí lo más fácil.

Ahora si queremos que el resultado nos dé en años, meses y días, el asunto se complica más. Supongamos que necesitamos un resultado algo así como 5 años, 2 meses y 25 días.

Para ello utilizaremos la siguiente fórmula:

=TEXTO(AÑO(A1-B1)-1900;"#")  & " años, " & TEXTO(MES(A1-B1)-1;"#") & "  meses, y " & TEXTO(DIA(A1-B1);"#") & " días"

Naturalmente que habrá que ajustar las referencias según las celdas que contienen las fechas a restar; en este caso hemos supuesto que las fechas están en A1 y B1.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

14 Opiniones
  1. Francisco dice:

    El error esta en el 1,900 no me sale la formula

  2. Patricia dice:

    Una consulta, como puedo pasar en Excel un intervalo de tiempo a representarlo en celda rellena y que cada celda sea un día, por ejemplo intervalo de tiempo del 1o. Se septiembre al 5 de septiembre quiero q aparezcan sombreado 5 días en el calendario previamente representado en celdas lineales del mes de septiembre. Mil gracias ojalá me puedan ayudar porque me toma hacer los registros manuales mucho tiempo. Saludos

  3. Hugo letelier dice:

    Hola me pueden ayudar por favor con la siguiente situación:

    Se que para calcular una cierta cantidad de días, inserto la fecha de ingreso y en otra celda coloco la formula =hoy() pero a la cantidad de días, necesito restar si la persona se fue antes de la fecha actual.
    No se que formula agregar.

    Saludos Cordiales

  4. MIRIAM dice:

    Muy buen aporte, me ayudo con lo que necesitaba, saludos!!

  5. Jackson dice:

    excelente, claro y conciso gracias por su aporte también fue de utilidad para mi

  6. Japp dice:

    Muchas gracias, me ayudo mucho desde Colombiaaa

  7. Ali dice:

    Gracias, me sirvió, pero cómo hago para que en el resultado no aparezca 30 o 31 días sino sume un mes más.

  8. Daniel dice:

    Estimados. Cuando copio o escribo la formula a mi planilla me aparece un mensaje de error en la formula, he intentado copiando y escribiendo la formula y de igual manera me da el mensaje de error, favor su ayuda

    • Lorito dice:

      Trata de cambiar los punto y coma por comas
      fíjate que la resta de celda sea de la mayor a menor

      • ANDREA dice:

        ME SALE EL MISMO ERROR... INTENTE CAMBIANDO ; POR , PERO SIGUE EL ERROR.... ME PUEDE COPIAR LA FORMULA CON LA CORRECCIÓN QUE CONSIDERA QUE DEBE ESTAR EL ERROR?

        • ANDREA dice:

          LISTO!!!! EL ERROR ERA QUE PRIMERO VA LA FECHA RECIENTE Y LUEGO LA MAS ANTIGUA....

          =TEXTO(AÑO(B1-A1)-1900;"#") & " años, " & TEXTO(MES(B1-A1)-1;"#") & " meses, y " & TEXTO(DIA(B1-A1);"#") & " días"

          • CLAUDIA dice:

            No me sale :'(
            donde me estoy equivocando, el error que me señala el excel es el numero 1900
            =TEXTO(AÑO(F6-C6)-1900;"#")&"años,"& TEXTO(MES(F6-C6)-1;"#")&"meses, y"&TEXTO(DIA(F6-C6);"#")&"días"

          • COMETINSTR dice:

            cambia los punto y coma por solo comas y selecciona primero la fecha mas reciente y despues la mas antigua

            =TEXTO(AÑO(B1-A1)-1900,"#") & " años, " & TEXTO(MES(B1-A1)-1,"#") & " meses, y " & TEXTO(DIA(B1-A1),"#") & " días"

  9. Yago García dice:

    Muchas gracias, me ha sido de mucha utilidad.
    Saludos desde España.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.