Sumar o restar horas en Excel

Para tareas en Excel como controlar el horario de los trabajadores, es preciso sumar y restar horas, proceso que requiere de cierta personalización para que funcione perfectamente.

Sumar y restar horas no es tan sencillo como sumar y restar la celda A1 con la B1, como se haría con cualquier otra operación aritmética.

Para que la suma o resta de horas en Excel funcione correctamente, tendremos que dar un formato de hora personalizado a las celdas involucradas en la operación.

Supongamos que queremos saber cuántas horas ha laborado un empleado que ingresó a las 8 horas y 15 minutos de la mañana y salió a las 12 y 45 minutos del medio día.

En la celda A1 colocamos la hora de ingreso, en la celda B1 colocamos la hora de salida, y en la celda C1 colocaremos el número de horas trabajadas, es decir, que allí colocamos la siguiente fórmula: =B1-A1.

Pero antes, a las tres celdas hay que darles un formato personalizado conocido como [h]:mm:ss

Con ello, el resultado de la resta o suma se mostrará en número de horas, minutos y segundos, que en el ejemplo supuesto aquí será 4:30:00 horas.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

3 Opiniones
  1. ruth dice:

    busco una formula que sea restar hora de incio con hora de salida menos una hora de almuerzo
    ejemplo
    inicio salida
    10:00 am 18:00 pm – una hora del almuerzo en total seria = 7 horas
    como saco esa formula
    yo tengo solo para sacar las horas
    +F6-E6+(E6>F6) = + hora de salida – hora de inicio + (hora de incio >hora de salida) me faltaria agregar menos una hora.

    • carolina dice:

      Me interesa esta respuesta también, ya que es para un formulario de ausencias y/o permisos.

      Gracias

    • José dice:

      Para cálculo de horas trabajadas menos 1 hora de almuerzo
      =SI(((C287-B287)-F287)>0;(C287-B287)-F287;0)
      C= Hora Salida
      B= Hora Entrada
      F= 1 hora almuerzo (Columna oculta, poner 1:00)
      El formato de las celdas debe ser 0:00 caso contrario no cálcula

      Ahora necesito su ayuda en el mismo tema, tengo ya las horas trabajadas El 8:30, cuando la jornada normal es de 8 horas por tanto hay que pagar 0:30, pero necesito que me transforme a cantidad es decir al equivalente en números no en tiempo es decir 0:30 que me ponga 0,50 (1/2 hora); y cuando sea lo contrario 7:30 es decir es 1/2 hora negativa -0:30 = -0;50 *Esto es para cálculo de pago de horas extras*

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.