Sumar o restar horas en Excel

Inicio » Excel para contadores. » (20 / 08 / 2009 )

Para tareas en Excel como controlar el horario de los trabajadores, es preciso sumar y restar horas, proceso que requiere de cierta personalización para que funcione perfectamente.

Sumar y restar horas no es tan sencillo como sumar y restar la celda A1 con la B1, como se haría con cualquier otra operación aritmética.

Para que la suma o resta de horas en Excel funcione correctamente, tendremos que dar un formato de hora personalizado a las celdas involucradas en la operación.

Manual de Excel Avanzado. Aproveche el potencial de Excel para hacer más productivo su trabajo.

Supongamos que queremos saber cuántas horas ha laborado un empleado que ingresó a las 8 horas y 15 minutos de la mañana y salió a las 12 y 45 minutos del medio día.

En la celda A1 colocamos la hora de ingreso, en la celda B1 colocamos la hora de salida, y en la celda C1 colocaremos el número de horas trabajadas, es decir, que allí colocamos la siguiente fórmula: =B1-A1.

Pero antes, a las tres celdas hay que darles un formato personalizado conocido como [h]:mm:ss

Con ello, el resultado de la resta o suma se mostrará en número de horas, minutos y segundos, que en el ejemplo supuesto aquí será 4:30:00 horas.

Recomiéndanos en

Google+ Facebook Twitter
Gerencie.com en su coreo
(Gratis - Reciba diariamente nuestras novedades en su correo)

Siéntase libre de opinar

63 Opiniones
  1. Juan Carlos Castillo dice:

    Buen dia, tengo que realizar una funcion que me permita condicionar el total de atrasos de una planilla de asistencia, por ejm: en la asistencia manejamos el termino de atraso "T", pero si el personal tiene 03 atrasos en el mes píerde su bono. Que funcion podria utilizar para poder condicionarlo con un permitido o menor o igual a 02 atrasos en el mes. Esta es la formula que estoy probando SI(A1:C1<="T",A1:C1*7.5,A1:C1*0). Agracedere me puedas ayudar con esta consulta que me es muy urgente atender.Slds.

  2. Fabián dice:

    Por favor, necesito calcular en la misma celda el tiempo entre por ejemplo, las 14:30 y las 19:00 horas. Cuando escribo en la celda =19:00-14:30 y doy enter, me sale error aunque a la celda le haya dado anteriormente formato de hora. Gracias

    • JUAN dice:

      NO PUEDES HACER OPERACIONES CON HORAS, SI LAS HORAS ESTAN EN CELDAS HAZ LA OPERACION EN UNA CELDA DIFERENTE Y RESTA LAS HORAS CON LOS NOMBRES DE LAS CELDAS, EXCEL NUNCA TE VA A PERMITIR REALIZAR ESTA OPERACION YA QUE NO SON TERMINOS.

  3. Sandra dice:

    Hola!

    Cómo hacer una tabla en xls indicando la hora de México (por ejemplo) + 10 hrs para saber cual es la hora de moscú?

    Gracias!

  4. F1numbers dice:

    Hola,

    me gustaría restar tiempos similares al siguiente --> 1:24.132 (siendo "1" los minutos, "24" los segundos y "132" las milésimas.
    No encuentro el formato adecuado para que la resta me dé resultado. ¿Alguien podría asesorarme?

    Gracias de antemano.

    @F1numbers

  5. osvaldo dice:

    mi correo es oaveliz@gmail.com gracias

  6. osvaldo dice:

    tengo en una planilla de excel celdas de distintos colores, como hago para que en una celda distinta me escriba por ejemplo un 1 si la celda a1 es de color azul, caso contrario escriba otro valor, por favor dar solucion a mi correo

  7. martin dice:

    He creado un Excel para los horas trabajado ('los partes del trabajo') en 2014 y tiene tambien un calendario con los dias festivas (en España, Madrid).Y tengo tambien un blog (en ingles) sobre el Excel:

    http://worktimesheet2014.blogspot.com.es/

    con el URL donde puedes bajar el Excel. Quizas os sirve como ejemplo como usar formulas para calcular horas y minutos.

  8. cris dice:

    hola.
    como puedo restar horas cuando tengo.
    00:05 a 1:15 me marca error :(

  9. tatiana dice:

    hola que pasa cuando el calculo me da mas de las 48 horas, como hago para sacar las horas extras a parte

  10. DAVID dice:

    Hola me gustaria resolver una duda mi horario es de 19:00 a 02:00 o de 7:00 PM a 2:00 AM y no se como restarlo para que no me salga almuadillas.
    muchas grcias

  11. margot de salazar dice:

    hola tu información me ayudo muchísimo. gracias. ahora bien me gustaría como multiplico el total de horas trbajados por su precio

  12. Jair Zilva dice:

    Hola, ya calculé las horas de lunes, martes, miercoles, etc, hahora necesito sumar todas pero inserto la formula =SUMA(B5:O5) por ejemplo pero me maraca error y si la hago así o crei conveniente utilizar =SUMA(B5:O5,"h:mm") como en la obtencion de diferencias entre hora de entrada y salida, pero me marca error tambien como puedo hacer esta simple suma de horas sin que me maruqe cero (0O
    :00) o error

    • Carlos Arellano dice:

      estimado Jair.
      Tu inquietud es muy poca ya que no sabemos si el calculo lo haz hecho para el lado o para abajo. Si es para el lado tienes yo hice un calculo como ejemplo, de la siguiente forma:
      =suma(A2+B2+C2+D2+E2)enter y me dio el resultado de la suma.
      Pruebalo, deberia resultar...

  13. juan carlos dice:

    X J V S D L M X J V S D L M X J V S D HORAS
    N N M T N N M T N 78,6
    Esta sería la formula completa:
    =CONTAR.SI(B10:AF10;"M")*7,15+CONTAR.SI(B10:AF10;"T")*7,15+CONTAR.SI(B10:AF10;"N")*10

    No entiendo lo que hago mal para que no me de el resultado en horas y minutos.

  14. juan carlos dice:

    ENERO 2014
    1 2 3 4 5
    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
    X J V S D L M X J V S D L M X J V S D L M X J V S D L M X J V HORAS DT
    vigilante 1 N M T N N M T N N M T N N N 0:00 14
    vigilante 2 T N N M T N N M T N N N M T N N N 00:00 17
    vigilante 3 M T N N M T N N N M T N N N M T T N N 165,25 19
    vigilante 4 M T N N N M T N N N M T T N N M M T N N N 182,5 21
    vigilante 5 M T N N N M T T N N M M T N N M T T N 159,75 19
    vigilante 6 M T T N N M M T N N M T N N M M T 139,75 17
    vigilante 7 N M M T N N M T N N M T N N M 128 15

    Esta es la formula: =CONTAR.SI(B11:AF11;"M")*7:15+CONTAR.SI(B11:AF11;"T")*7:15+CONTAR.SI(B11:AF11;"N")*10
    pero no me da el total de horas trabajas, a ver si me echáis una manita.

    • Hernando Carvajalino dice:

      Le recomiendo que haga una revisada a los formatos de las Horas, que hay varios… y haga ejercicios sencillos, con diferentes formatos.
      07:00:00 a.m. 11:25:00 a.m. 03:30:00 p.m. 03:30:00 a.m.
      07:00:00 a.m. 11:25:00 a.m. 03:30:00 p.m. 03:30:00 a.m.
      7:00:00 a.m. 11:25:00 a.m. 3:30:00 p.m. 3:30:00 a.m.
      7:00:00 11:25:00 15:30:00 3:30:00
      07:00:00 11:25:00 15:30:00 03:30:00

  15. javier dice:

    Buenos dias

    A veces en excel hay horas militares que no me permite restar, ej:

    19:25 - 05:00. Como realizo esta operacion sin que me de un error?

    • Hernando Carvajalino dice:

      Le recomiendo que haga una revisada a los formatos de las Horas, que hay varios... y haga ejercicios sencillos, con diferentes formatos.
      07:00:00 a.m. 11:25:00 a.m. 03:30:00 p.m. 03:30:00 a.m.
      07:00:00 a.m. 11:25:00 a.m. 03:30:00 p.m. 03:30:00 a.m.
      7:00:00 a.m. 11:25:00 a.m. 3:30:00 p.m. 3:30:00 a.m.
      7:00:00 11:25:00 15:30:00 3:30:00
      07:00:00 11:25:00 15:30:00 03:30:00

  16. juan dice:

    amigo como calculo estas horas:
    Inicio de trabajo 15:00hr y Salida 02:00hrs

  17. Nestor dice:

    EStimados necesito urgente ayuda con una fórmula en horas. El tema es el siguiente: Si entre la hora de entrada y la hora de salida el resultado es mayor que las horas contratadas son extras y si el resultado es menos son faltantes. Gracias.
    Me complica utilizar valores formato hora. Así debiera quedar.

    Hs. contratadas Ingreso Egreso Hs. Trabaja Hs. Faltan Hs. Extr
    8:00 10:00 22:00 12:00 0 4:00

    • Hernando Carvajalino dice:

      Solución:
      HC HI HS HT HF HE
      8:00 10:00 22:00 12:00 0 4:00
      8:0 10:0 22:0 =C2-B2 =SI(A2>D2;A2-D2;"0") =SI(D2>A2;D2-A2;"0")
      Espero haberle ayudado.

      • Hernando Carvajalino dice:

        HC____HI____HS____HT______HF___________________HE
        8:00__10:00_22:00_12:00 0_4:00_________________0
        8:0___10:0__22:0__=C2-B2__=SI(A2>D2;A2-D2;"0")_=SI(D2>A2;D2-A2;"0")

  18. Hernando Carvajalino dice:

    Para colaborarle con el planteamiento:

    Abrió 19/01 16:15:08 Formato: dd/mm hh:mm:ss
    Cerró 23/01 07:29:51 Formato: dd/mm hh:mm:ss
    HorasMin 87:14 Formato: [h]:mm

    "Espero que con la lectura de la formula y viendo bien la manera de escribir la fecha y la hora logre entender el sencillo ejercicio."

    digita en B1: 19-1e16:15:08
    la "e" significa espacio!

    Con gusto, espero le ayude!

    • Hernando Carvajalino dice:

      Me quedo por decirle que en
      B1 coloca 19-1e16:15:08 con el formato mostrado, en
      B2 coloca 23-1e7:29:51 con el formato mostrado
      B3 escribe "=B2-B1" con el formato mostrado.
      Para lograr el resultado esperado.

  19. saidun dice:

    Hola expertos, a ver si alguien tiene la amabilidad de resolverme este cálculo:

    por ejemplo, si una incidencia se abrió el 19 de enero a las 16h15m08s y se cerró el 23 de enero a las 07h29m51s, ¿cuál es el total sólo de horas y minutos que se ha tardado en resolver la incidencia?

    Gracias de antemano.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.