Sumar o restar horas en Excel

Inicio » Excel para contadores. » (20 / 08 / 2009 )

Para tareas en Excel como controlar el horario de los trabajadores, es preciso sumar y restar horas, proceso que requiere de cierta personalización para que funcione perfectamente.

Sumar y restar horas no es tan sencillo como sumar y restar la celda A1 con la B1, como se haría con cualquier otra operación aritmética.

Para que la suma o resta de horas en Excel funcione correctamente, tendremos que dar un formato de hora personalizado a las celdas involucradas en la operación.

Supongamos que queremos saber cuántas horas ha laborado un empleado que ingresó a las 8 horas y 15 minutos de la mañana y salió a las 12 y 45 minutos del medio día.

En la celda A1 colocamos la hora de ingreso, en la celda B1 colocamos la hora de salida, y en la celda C1 colocaremos el número de horas trabajadas, es decir, que allí colocamos la siguiente fórmula: =B1-A1.

Pero antes, a las tres celdas hay que darles un formato personalizado conocido como [h]:mm:ss

Con ello, el resultado de la resta o suma se mostrará en número de horas, minutos y segundos, que en el ejemplo supuesto aquí será 4:30:00 horas.

Recomiéndanos en

Google+ Facebook Twitter
Gerencie.com en su correo
(Gratis - Reciba diariamente nuestras novedades en su correo)

Siéntase libre de opinar

65 Opiniones
  1. Ariel Saavedra dice:

    Por si a alguien le sirve la siguiente formula que realicé de buscar y no encontrar un resultado que me sirviera, esta fórmula calcula la diferencia de horas entre una hora1 y una hora2 (ambas en el formato 00:00:00), supongamos que en la celda A1 se encuentra la hora1, y en la celda B1 se encuentra la hora2, la formula es la siguiente:

    =SI(A2>=B2;24;0)-HORA(A2)+HORA(B2)+MINUTO(B2)/60-MINUTO(A2)/60-SEGUNDO(A2)/3600+SEGUNDO(B2)/3600

    Ejemplos de resultados de la formula (deben dejar el campo en formato general o número):

    - horas entre "hora1" y "hora2" = x
    - horas entre 8:00:00 y 14:00:00, nos da como resultado = 6
    - horas entre 22:30:00 y 7:15:00, nos da como resultado = 8,75
    - horas entre 20:34:45 y 5:59:28, nos da como resultado = 9,411944444

    Saludos

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.