Sumar en Excel valores de una fecha determinada

Excel permite sumar los valores causados en las fechas que el usuario elija, de modo que si queremos sumar todas las ventas del mes de junio, Excel se encargará de ello.

Supongamos que nos entregan un listado con las ventas realizadas durante todo el año, sin clasificar y naturalmente sin sumar.

No es necesario primero ordenar las ventas según la fecha, y luego sacar subtotales para luego hallar el valor total; claro que si está ordenado de esa forma, mucho mejor.

Pero en este caso supondremos un listado en completo desorden, del cual debemos saber qué ventas se realizaron en un determinado mes, sin tener que ponernos en la tediosa tarea de ordenar todas las ventas según su fecha.

Para ello utilizaremos una fórmula matricial, en la celda donde queremos ubicar el resultado.

Supongamos una base de datos ordenada de la siguiente forma:

Columna A: número de la factura
Columna B: fecha de la factura
Columna C: nombre del cliente
Columna D: valor de la factura

En este caso, sólo nos importa la fecha y el valor de la factura, esto es, las columnas B y D.

Luego, en la celda donde queremos el resultado, colocamos la siguiente fórmula:

=SUMA((MES(B4:B1000)=12)*(D4:D1000))

La fórmula le está diciendo a Excel que tome sume las facturas que correspondan al mes 12. Si queremos otro mes, cambiamos ese 12 por el numero del mes. Las celdas donde están las fechas, naturalmente que deben tener el formato fecha, preferiblemente el formato día/mes/año [25/06/08], es decir, 25 de junio de 2008.

El primer rango, esto es B4:B1000, corresponde a las celdas donde están las fechas, y el segundo rango, esto es, D4:D1000, corresponde a las celdas donde están los valores de las facturas.

Lo que Excel hará, es buscar las facturas del mes 12 en el rango B4:B1000 y sumar los valores que corresponden a dichas facturas.

Como se trata de una fórmula matricial, para que funcione, una vez se escriba la fórmula, en lugar de presionar la tecla Enter, presione simultáneamente las teclas Shift, Ctrl, Mayúscula y Enter. Las cuatro teclas deben ser presionadas simultáneamente, de lo contrario la fórmula no le servirá.

Una vez presiones las teclas anteriores, verá que su fórmula ha quedado de la siguiente forma:

{=SUMA((MES(B4:B1000)=12)*(D4:D1000))}

Cada vez que modifique la fórmula, deberá presionar simultáneamente la misma combinación de teclas.

Descargar archivo de ejemplo

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

Una opinión
  1. Edison beltran dice:

    No entiendo la lógica de utilizar un “*” …se debería multiplicar el resultado no?

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.