Contar las palabras que hay en una celda de Excel

Por

En algunos casos nos vemos en la necesidad de saber cuántas palabras hay en una celda de Excel, lo que es sencillo de determinar si es una sola celda, pero si son muchas, lo mejor es echar mano de una fórmula que automatice el proceso.

Implementar la fórmula res relativamente sencillo si en la celda no hay más espacios que los normales que separan las palabras, pero si entre las palabras, o al final o inicio de la frase hay espacios que no deberían estar, ya no es tan sencillo.

Fórmula para contar palabras sin espacios adicionales

Como se decía, si la celda no tiene espacios adicionales esta fórmula servirá:

=LARGO(A1)-LARGO(SUSTITUIR(A1;" ";""))+1

Esta fórmula funciona si no hay espacios al inicio o al final, y si cada palabra está separada únicamente por un espacio.

Fórmula para contar palabras con espacios adicionales

Si hay espacios al inicio y al final, o si entre una palabra y otra hay más de un espacio, hay que ajustar la fórmula para descuente esos espacios y no los cuente como una palabra más.

La fórmula será:

=SUMA(SI(LARGO(ESPACIOS(A1))=0;0;LARGO(ESPACIOS(A1))-LARGO(SUSTITUIR(A1;" ";""))+1))

Aquí hemos supuesto que las palabras a contar están en la celda A1, de modo que es preciso ajustar el rango según donde estén ubicadas las celdas a contar.

Luego no es sino arrastrar la fórmula hacia abajo tantas filas como celdas tengamos que contar.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.

¿Preocupado por su pensión? Manténgase Informado.