Función Si con funciones lógicas anidadas en Excel

La función condicional SI es de gran utilidad en Excel y si la utilizamos en combinación con funciones lógicas, incluso anidadas, los resultados son prometedores.

Para tratar de explicar su funcionamiento y utilidad, haremos un sencillo ejemplo que trate de recoger la función condicional SI y las funciones lógicas Y, y O.

Supongamos que la empresa remunera al trabajador con una comisión según el valor de sus ventas y según el precio con que coloque los productos. Supongamos que la empresa maneja 2 precios  para sus productos, y el vendedor por supuesto tratará de colocar el producto al  precio más alto, siendo remunerado también por ello.

Veamos las condiciones:

  1. Si el trabajador vende más de 10.000.000 al mes y coloca los productos con el precio 2, la comisión será del 10%.
  2. Si el trabajador vende más de 10.000.000 al mes y coloca los productos con el precio 1, la comisión será del 4%.
  3. Si el trabajador vende menos de 10.000.000 pero coloca los productos al precio 2, la comisión será del 2%.
  4. Si el trabajador vende menos de 10.000.00  pero coloca los productos al precio 1, la comisión será del 1%.
  5. Si el trabajador no hace nada de lo anterior, la comisión será del 0%.

Luce complicado, ¿verdad?

En los primero dos puntos, existen dos condiciones y las dos se deben cumplir para tener derecho a la comisión allí fijada. Si una de las condiciones no se cumple, no hay lugar a la comisión señalada. Por ello utilizamos la función lógica Y, que le indica a Excel que las dos condiciones se deben cumplir. Que la venta sea mayor a… y que el precio de venta sea…

Los puntos 3 y 4, también contienen dos condiciones, pero con que se cumpla una de ellas dará lugar a la comisión pactada. La idea es que el empleado  venda más de 10.000.000 al mes, pero si no lo hace y  coloca los productos a un precio mayor, se le dará una comisión determinada. Allí se utiliza la función lógica O, que le dice a Excel que aplique la comisión si una de las dos condiciones se cumple.

El punto 5 nos dice que si no se da ninguno de los supuestos planteados, es decir que el trabajador no cumplió con ninguno de sus objetivos, no tendrá derecho a comisión alguna y el resultado será 0.

La fórmula para recoger lo anterior será la siguiente:

=SI(Y(B2>10000000;C2=2);"10%";SI(Y(B2>10000000;C2=1);"4%";SI(O(B2>10000000;C2=2);"2%";SI(O(B2>10000000;C2=1);"1%";0))))

Aquí hemos supuesto que las ventas están en la celda B2 y el precio al que se colocaron en la celda C2.

Con esta fórmula en una celda se hacen todos los cálculos necesarios y se obtiene el valor deseado.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

36 Opiniones
  1. AG dice:

    Necesito aplicar una formula en un reporte con cambios diarios.
    En el excel tengo 2 hojas, una con la información que capturo diariamente, y otra con una conexión SQL Server que me muestra los insumos en la columna "B" y los precios en la columna "C"

    Necesito que la fórmula busque el valor de la hoja 2 columna "B" que coincida con el valor de "D2" de la hoja 1 y lo muestre en "J2" con el precio que se encuentra en la columna "C".

  2. carolina rincon dice:

    Hola,
    solicito de su colaboración, debo calcular la fecha en la que debo dar respuesta a una solicitud, teniendo en cuenta que solo tengo 3 horas para hacerlo, pero cuento con un horario hábil de 8 am a 6 pm, ejemplo: si mi solicitud llega a las 17:00:00 tengo 3 horas para dar respuesta seria a las 20:00:00, pero como laboro hasta las 18:00:00 requiero que me sume esas 2 horas faltantes al día hábil siguiente en mi horario hábil es decir a partir de las 8 :00:00. en conclusión esa respuesta debería quedar a las 10:00:00. tengo esta formula: =IF(AND(HOUR(B5+$M$1)>=18,MIN(B5+$M$1)>0),TEXT(WORKDAY.INTL(B5,1,1),"dd/mm/yyyy ")&TEXT($N$1,"hh:mm"),B5+$M$1)
    donde B5 es la hora de recibido de la solicitud, M1 son las 3 horas, pero me falta sacar la diferencia, cuando al sumar las 3 horas supera las 18:00, para que sumen al día hábil siguiente. gracias

  3. CELINA PEIMBERT dice:

    QUIERO UTILIZAR LA CONDICIÓN SI, CON BASTANTES OPCIONES, PERO LA FORMULA TIENE UN LIMITANTE DE ESPACIOS PERMITIDOS, EJEMPLO:
    =SI(B31=26104,N6,SI(B31=31301,N7,SI(B31=31401,N8,SI(B31=31501,N9,SI(B31=31801,N10,SI(B31=32201,N11,SI(B31=32301,N12,SI(B31=32502,N13))))))))
    LA FORMULA FUNCIONA TAL COMO ESTA EN CASO CONTRARIO DE DARLE UN VALOR DIFERENTE A LA CELDA B31 ME DA FALSO, PERO NECESITO QUE ESTA FORMULA FUNCIONE PARA MAS VALORES Y RESULTADOS, COMO LE PUEDO AGREGAR MÁS...????

  4. ISABEL LUGONES VENTURA dice:

    si la calificación final está entre 9,5 y 10, obtiene 80% de beca
    si la calificación final está entre 8,5 y 9,4 obtiene un 40%
    si la calificación final está 8,0 y 9,4 obtiene un 25% de beca
    si la calificación final está 8,0 y 8,4 obtiene un 25%
    si la calificación final está a 7,9 no se otorga beca.

  5. Ana dice:

    Hola
    Tengo un problema he tratado de generar la función SI para una fecha determinada, es decir, en mi celda tengo una fecha con hora 12/04/16 12:00 y en otra quiero determinar que si la hora de esa fecha es menor que 04:00 pm me sume 12 horas más y si es mayor que las 04:00 pm me sume 18 horas mas...ya le intente pero no me sale, hojala me puedan ayudar.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.