Función Si con funciones lógicas anidadas en Excel

La función condicional SI es de gran utilidad en Excel y si la utilizamos en combinación con funciones lógicas, incluso anidadas, los resultados son prometedores.

Para tratar de explicar su funcionamiento y utilidad, haremos un sencillo ejemplo que trate de recoger la función condicional SI y las funciones lógicas Y, y O.

Supongamos que la empresa remunera al trabajador con una comisión según el valor de sus ventas y según el precio con que coloque los productos. Supongamos que la empresa maneja 2 precios  para sus productos, y el vendedor por supuesto tratará de colocar el producto al  precio más alto, siendo remunerado también por ello.

Veamos las condiciones:

  1. Si el trabajador vende más de 10.000.000 al mes y coloca los productos con el precio 2, la comisión será del 10%.
  2. Si el trabajador vende más de 10.000.000 al mes y coloca los productos con el precio 1, la comisión será del 4%.
  3. Si el trabajador vende menos de 10.000.000 pero coloca los productos al precio 2, la comisión será del 2%.
  4. Si el trabajador vende menos de 10.000.00  pero coloca los productos al precio 1, la comisión será del 1%.
  5. Si el trabajador no hace nada de lo anterior, la comisión será del 0%.

Luce complicado, ¿verdad?

En los primero dos puntos, existen dos condiciones y las dos se deben cumplir para tener derecho a la comisión allí fijada. Si una de las condiciones no se cumple, no hay lugar a la comisión señalada. Por ello utilizamos la función lógica Y, que le indica a Excel que las dos condiciones se deben cumplir. Que la venta sea mayor a… y que el precio de venta sea…

Los puntos 3 y 4, también contienen dos condiciones, pero con que se cumpla una de ellas dará lugar a la comisión pactada. La idea es que el empleado  venda más de 10.000.000 al mes, pero si no lo hace y  coloca los productos a un precio mayor, se le dará una comisión determinada. Allí se utiliza la función lógica O, que le dice a Excel que aplique la comisión si una de las dos condiciones se cumple.

El punto 5 nos dice que si no se da ninguno de los supuestos planteados, es decir que el trabajador no cumplió con ninguno de sus objetivos, no tendrá derecho a comisión alguna y el resultado será 0.

La fórmula para recoger lo anterior será la siguiente:

=SI(Y(B2>10000000;C2=2);"10%";SI(Y(B2>10000000;C2=1);"4%";SI(O(B2>10000000;C2=2);"2%";SI(O(B2>10000000;C2=1);"1%";0))))

Aquí hemos supuesto que las ventas están en la celda B2 y el precio al que se colocaron en la celda C2.

Con esta fórmula en una celda se hacen todos los cálculos necesarios y se obtiene el valor deseado.

MÁS SOBRE

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

32 Opiniones
  1. Willy dice:

    Tengo los siguientes valores en celdas:

    N5=10
    D100=7.055
    E100=2407.05
    E110=2457.05

    En D101 Estoy tratando de aplicar la fórmula:

    =SI(Y(E100+N5<E110,D100<N5,N5),SI(Y(E100+N5<E110,D100<E110,D100+N5,0))

    Pero esta fórmula me da error. He tratado de varias formas y nada.
    Qué estoy haciendo mal Carlos.

    Ayúdeme.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc. Lo que no está permitido es insultar o escribir palabras ofensivas o soeces. Si lo hace, su comentario será rechazado por el sistema o será eliminado por el administrador. Por último, trate de no escribir en mayúscula sostenida, resulta muy difícil leerle.