Función BUSCARV condicionada en Excel

La función BUSCARV nos permite encontrar un determinado valor en una base de datos o en un rango determinado de Excel, y dicha función la podemos condicionar según el criterio que se requiera.

Supongamos que necesitamos averiguar cuanto nos adeuda un determinado cliente sólo si este tiene una mora de 30 o más días. Si su mora es de menos de 30 días no necesitamos que la función haga la búsqueda.

Vamos a suponer que en la columna A se tiene el nombre del cliente y en la B el valor de su deuda. Supongamos ahora que en la celda C2 tenemos los días de mora del cliente, valor que se puede obtener mediante una función Buscarv.

La fórmula sería:

=SI(C2>=30;BUSCARV("Tomas";A2:B10;2);0)

La fórmula está compuesta de dos partes. La primera corresponde a al condicional (SI(C2>=30) y la segunda a la función buscar como tal (BUSCARV("Tomas";A2:B10;2).

Si la condición se cumple, la función Buscarv hará su trabajo y traerá el resultado o valor que le corresponde al valor buscado (deuda del cliente). Si no se cumple, arrojará 0 como resultado.

La función Buscarv (BUSCARV("Tomas";A2:B10;2), contienen en primer lugar el valor referencia a buscar (Ernesto en este caso), valor que debe buscar en el rango A2:B10, y el valor que debe llamar o traer, es decir la deuda que tiene, que se encuentra en la columna siguiente (2). Recordemos que el nombre del cliente está en A y su deuda en B, y es la deuda que nos interesa traer si se cumple el criterio días de mora.

En lugar de escribir el nombre del empleado que nos interesa, podemos llamarlo desde una celda, supongamos D2, y en tal caso la fórmula sería:

=SI(C2>=30;BUSCARV(D2;A2:B10;2);0)

Esta fórmula se puede complicar más según lo que necesitemos, puesto que en la misma podemos agregar por ejemplo, el cálculo automático de intereses según el tiempo de mora, pero eso será para una próxima oportunidad.

Descarga anexo

Recomendados.

Compártalo en Facebook Compártalo en Twitter

Déjenos su opinión

4 Opiniones
  1. agicar Dice:

    Hola,

    Tengo una pregunta tengo una tabla con 5 columnas
    ZONA CALLES 1 CALLE2 KR 1 KR2
    BOSA 3 -400 -201 59 400
    SANTA LIBRADA -200 -45 -30 58
    BOSA 2 -200 -35 59 190
    RESTREPO 1 -44 13 -30 14
    RESTREPO 2 -44 13 15 58
    BOSA 1 -34 14 59 190
    PERIFERIA OCCIDENTE 2 1 80 200 399
    SASAIMA 1 80 400 499
    CENTRO ORIENTE 14 45 -30 50
    FONTIBON 15 55 51 190
    CHAPINERO ORIENTE 46 75 -30 7
    CHAPINERO 46 75 8 50
    ENGATIVA 56 126 51 190
    LOS ROSALES 76 93 -30 10
    NIZA 76 93 11 50
    CHICO NORTE 94 122 -30 15
    NAVARRA 94 122 16 50
    UNICENTRO 123 152 -30 15
    TOBERIN 123 152 16 52
    SUBA OCCIDENTE 127 152 53 190
    MULTIPARQUES 153 234 -30 190
    PERIFERIA NORTE 2 235 799 -30 799

    la calle 1 es menor que la calle 2
    la carrera 1 es menor que la carrera 2

    En ese orden de ideas con la calle y la carrera puedo encontrar la zona, pero me toca hacer otra tabla adicional, para poderlo hallar. y de acuerdo de las zonas así mismo es la cantidad de columnas adicionales que tengo que usar.

    La pregunta es si por medio de varias formulas se puede hacer en una sola celda?

    Responder
    • EDGAR REYES Dice:

      Usa la funcion Si y la funcion Y anidada, ej: si esta entre la calle tal y la calle tal y la carrera tal y la carrera tal entonces “chapinero” en tu caso como son valores numéricos seria “si es mayor que” y “menor que” entonces “nombre de la localidad”. Y vas colocando las condiciones para cada localidad así si los valores están en ese rango te dira la localidad barrio.

      Responder
  2. Erik Urquidi Dice:

    Gracias,

    Me hizo caer en cuenta la importancia de donde se debe de colocar el paréntesis o bueno cerrar la función, para poder tener valores numericos y no la validacion de verdadero o falso.

    Responder
  3. ANONIMO Dice:

    Hola
    tengo la siguiente duda, tengo 2 hojas en un libro excel, la primera hoja tiene las facturas emitidas por SII, en la segunda hoja las facturas que se encuentran factorizadas, necesito saber que facturas de la hoja 2 se encuentran en la hoja 1.

    que formula ocupo? gracias!!

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.