Las funciones condicionales en Excel

Excel tiene una serie de funciones condicionales que permiten hacer cálculos a partir de una condición que se cumple, lo que hace más flexibles y personalizables los cálculos, potenciando las la utilidad de Excel.

Qué es una función condicional.

Una función condicional es aquella que nos permite realizar una acción siempre y cuando se cumpla con una condición determinada por el usuario.

Por ejemplo, cuando se quiere saber cuales fueron las ventas de un empleado, caso en el cual Excel sumará sólo las ventas de Carlos, por ejemplo.

Excel tiene algunas funciones condicionales por defecto, como SUMAR.SI, CONTAR.SI, pero nosotros podemos crear nuestras propias funciones condicionales a partir de la función SI.

Por ejemplo:

=SI(A2>10;B4*C4-D4;0)

Aquí se observa que B4 se multiplica con C4 siempre que A2 sea mayor a 10. Si no se cumpla tal condición, el resultado será cero.

La condición puede ser un valor o  un texto,  según el dato o valor que esté en la celda que sirve de referencia.

¿Cómo realizar una función condicional?

Supongamos la siguiente lista de empleados con las respectivas ventas mensuales.

Empleado Ventas
Mauricio  $ 1.350.000,00
Ana  $ 1.760.000,00
Jorge  $ 1.800.000,00
Juan  $ 1.356.000,00
Alba  $ 1.280.000,00
Francy  $ 1.620.000,00

Supongamos ahora que necesitamos saber cuántos empleados tuvieron ventas superiores a $1.500.00.

Para ello utilizamos la función condicional CONTAR.SI, que contará los valores que cumplan la condición, que es ser superior a $1.500.00.

La fórmula será así:

=CONTAR.SI(B2:B7;">1500000")

La condición la podemos colocar en una celda que sirve de referencia, por ejemplo en C2, donde colocaremos el valor condicional, y la fórmula quedaría así:

=CONTAR.SI(B2:B7;>C2)

Por supuesto en C2 ingresamos 1.500.000, que es la condición, y como se observa, la referencia en la celda no se coloca entre comillas.

Lo que hace la función es revisar el rango B2:B7 donde están las ventas de los empleados, y contar cuántos cumplen con el criterio o condición dada, que, en este caso, es superior a 1.5000.000.

Existen varias funciones condicionales en Excel, que se identifican por tener .SI en su estructura, que indica la condición.

Recomendados.

Compártalo en Facebook Compártalo en Twitter
Gerencie.com en su correo.

Suscríbase y enviaremos a su correo nuestra información mas reciente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.