Funciones condicionales en Excel

Excel tiene una serie de funciones condicionales que permiten hacer cálculos a partir de una condición que se cumple, lo que hace más flexibles y personalizables los cálculos, potenciando las la utilidad de Excel.

Condicionales en Excel

Una función condicional es aquella que nos permite realizar una acción siempre y cuando se cumpla con una condición determinada por el usuario.

Por ejemplo, cuando se quiere saber cuales fueron las ventas de un empleado, caso en el cual Excel sumará sólo las ventas de Carlos, por ejemplo.

Excel tiene algunas funciones condicionales por defecto, como SUMAR.SI, CONTAR.SI, pero nosotros podemos crear nuestras propias funciones condicionales a partir de la función SI.

Ejemplo de función condicional en Excel.

Un ejemplo de una función condicional en Excel sería el siguiente:

=SI(A2>10;B4*C4-D4;0)

Aquí se observa que B4 se multiplica con C4 siempre que A2 sea mayor a 10. Si no se cumpla tal condición, el resultado será cero.

La condición puede ser un valor o  un texto,  según el dato o valor que esté en la celda que sirve de referencia.

¿Cómo realizar una función condicional?

Supongamos la siguiente lista de empleados con las respectivas ventas mensuales.

Empleado Ventas
Mauricio  $ 1.350.000,00
Ana  $ 1.760.000,00
Jorge  $ 1.800.000,00
Juan  $ 1.356.000,00
Alba  $ 1.280.000,00
Francy  $ 1.620.000,00

Supongamos ahora que necesitamos saber cuántos empleados tuvieron ventas superiores a $1.500.00.

Para ello utilizamos la función condicional CONTAR.SI, que contará los valores que cumplan la condición, que es ser superior a $1.500.00.

La fórmula será así:

=CONTAR.SI(B2:B7;">1500000")

La condición la podemos colocar en una celda que sirve de referencia, por ejemplo en C2, donde colocaremos el valor condicional, y la fórmula quedaría así:

=CONTAR.SI(B2:B7;>C2)

Por supuesto en C2 ingresamos 1.500.000, que es la condición, y como se observa, la referencia en la celda no se coloca entre comillas.

Lo que hace la función es revisar el rango B2:B7 donde están las ventas de los empleados, y contar cuántos cumplen con el criterio o condición dada, que, en este caso, es superior a 1.5000.000.

Existen varias funciones condicionales en Excel, que se identifican por tener .SI en su estructura, que indica la condición.

Condicionales anidadas en Excel.

Se pueden anidar varias condicionales en Excel dependiendo de los valores que se requieren comprobar.

Supongamos el caso de las comisiones por ventas de los trabajadores donde se plantean los siguientes rangos:

Valor de la venta Porcentaje de comisión.
<1.000.000 5%
>2.000.000 10%
>5.000.000 15%

La fórmula condicionada sería algo así:

=SI(A1<100000;A1*0.05;SI(A1>=2000000;A1*0.1;SI(A1>5000000;A1*0,15)))

Se han anidado 3 condiciones, pues existen tres rangos y 3 tarifas, que se aplicarán al rango que corresponda.

Condicionales combinadas.

Hasta aquí hemos visto cómo introducir una condicional, pero hay casos en que se deben cumplir 2 condiciones.

Es el caso de las tarifas de impuestos progresivas donde se la tarifa es diferente para cada rango.

Por ejemplo:

Si su renta es mayor a 1.000.000 pero menor que 2.000.000 entonces paga una tarifa del 20%. En este caso debe cumplir dos condiciones, ser mayor de 1 millón, pero menor de dos millones, es decir, entre 1 y 2 millones.

La fórmula condicionada sería algo así:

=SI(Y(A1=<1000000;B1>2000000);B1*0,2;0)

Cuando los rangos son muchos el resultado es una fórmula como la siguiente:

=SI(C6<=95;0;SI(Y(C6>95;C6<=150);(C6-95)*0,19;SI(Y(C6>150;C6<=360);((C6-150)*0,28)+10;SI(Y(C6>360;C6<=640);((C6-360)*0,33)+69;SI(Y(C6>640;C6<=945);((C6-640)*0,35)+162;SI(Y(C6>945;C6<=2300);((C6-945)*0,37)+268;SI(C6>=2300;(C6-2300)*0,39+770)))))))

Aquí no solo se cumplen dos condiciones al tiempo, sino que se anidan diferentes condicionales combinadas, por lo que la formula será tan compleja como los cálculos que se requieren hacer.

Recomendados.

Compártalo en Facebook Compártalo en Twitter

Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.