Extraer el mes en texto de una fecha de Excel

Cuando en una celda de Excel se presenta una fecha del tipo 29/11/2020m, por ejemplo,  podemos extraer el mes en texto, ya que  está representado en números.

Como extraer el mes de una fecha en Excel.

Supongamos que la fecha está en la celda A2. En cualquier celda colocamos la siguiente fórmula:

=MES(A2)

Esta fórmula nos extrae el mes en número, que en el ejemplo es 11, pero lo necesitamos en texto que es el mes de Noviembre.

Una forma de hacerlo es con la función texto precisamente. Y se hace de la siguiente forma:

=TEXTO(A2;MMMM")

Si lo que se quiere convertir en texto es el día, cambiamos la M por la D y tendríamos:

=TEXTO(A2;"DDDD")

Otra forma de hacerlo es utilizando la función BUSCARV. Es un poco más compleja debido a que se necesitan datos adicionales, pero la expondremos debido a que el funcionamiento de BUSCARV que es muy útil en muchos casos.

En este caso hay que crear una columna con los números de los meses (1 a 12) y otra con los meses en texto al frente de cada número. Luego se aplica la siguiente formula:

=BUSCARV(MES(A2);E1:F12;2;0)

La fórmula se puede complicar un poco más para hacer que el texto aparezca de la siguiente forma: jueves 5 de septiembre de 2013, lo cual se logra con la siguiente fórmula:

=CONCATENAR(TEXTO(A2;"DDDD "); DIA(A2); " de ";TEXTO(A2;"MMMM");" de ";TEXTO(A2;"YYYY"))

Descargar archivo de Excel.

Recomendados.

Compártalo en Facebook Compártalo en Twitter
Gerencie.com en su correo.

Suscríbase y enviaremos a su correo nuestra información mas reciente.


Déjenos su opinión

Una opinión
  1. Horacio Carrasco P. Dice:

    Gracias, con la función mes solucionado mi tema, Slds

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.