Extraer texto entre paréntesis en Excel

En algún momento nos puede ser útil poder extraer el texto que se encuentre entre paréntesis en una celda de Excel, proceso que se puede automatizar con una serie de fórmulas.

Cómo extraer texto entre paréntesis

Por ejemplo puede ser el caso en que encontremos lo siguiente:

  • Medellín (Antioquia)
  • Ibagué (Tolima)
  • Girardot (Cundinamarca)
  • Cali (Valle), Colombia.

Quizás necesitemos extraer a una celda de Excel únicamente el nombre del departamento que se encuentra entre paréntesis.

Para ello haremos uso de la siguiente fórmula:

=SI.ERROR(EXTRAE(A1;ENCONTRAR("(";A1)+1;ENCONTRAR(")";A1)-ENCONTRAR("(";A1)-1);"")

Aquí hemos supuesto que los datos están en A1, luego si están en otra celda sólo habrá que modificarla. Luego se arrastra hacia abajo para las demás celdas.

Lo que hace esta formula es extraer lo que encuentre dentro de los paréntesis.

Si queremos extraer incluso los paréntesis, modificamos un poco la fórmula:

=SI.ERROR(EXTRAE(A1;ENCONTRAR("(";A1);ENCONTRAR(")";A1)-ENCONTRAR("(";A1)+1);"")

Nótese que hemos eliminado +1 que indica el lugar desde donde debe extraer una vez ubicado el valor referencia, en este caso el paréntesis que abre “(“, y el -1 del final lo hemos cambiado por +1 para indicar que extraiga incluso el valor referencia final encontrado “)”.

Este conjunto de fórmulas aplica para extraer cualquier criterio, no sólo valores entre paréntesis, sino valores que están después de un guion, por ejemplo, o entre comillas.

Por último, si quisiéramos extraer únicamente la primera parte, palabra o palabra, es decir, todo lo que está antes del paréntesis o el valor que le indiquemos, la fórmula será:

=SI.ERROR(IZQUIERDA(A4;ENCONTRAR("(";A4)-1);A4)

La función SI.ERROR se utiliza para cuando no haya que mostrar dentro de los criterios fijados, simplemente nos deje una celda en blanco.

Extraer texto entre comillas.

Supongamos que tenemos el siguiente texto entre comillas:

Bogotá "DC"

Para extraer la DC utilizamos la siguiente fórmula:

=SI.ERROR(EXTRAE(A2;ENCONTRAR("""";A2)+1;ENCONTRAR("""";A2;ENCONTRAR("""";A2)+1)-ENCONTRAR("""";A2)-1);"")

Estas fórmulas se colocan en las celdas en la que se pretende colocar el texto extraído, y luego arrastramos hacia abajo para cubrir todo el rango de datos que necesitamos.

Forma de citar este artículo (APA):

Gerencie.com. (2012, septiembre 12). Extraer texto entre paréntesis en Excel [Entrada de blog]. Recuperado de https://www.gerencie.com/extraer-texto-entre-parentesis-en-excel.html

Recomendados.

Compártalo en Facebook Compártalo en Twitter
Deje su opinión o su pregunta.

Regístrese para informarle cuando se responda su pregunta.

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.