Redondeo o aproximación de cifras en Excel

Excel nos permite redondear o aproximar valores al entero más cercano, incluso la decena, centena o mil más cercano.

Aproximación de cifras en Excel.

Para aproximar un número a su cifra o valor más cercano en Excel, se puede recurrir a la función REDONDEAR para aproximar valores al valor más cercano, ya sea hacia arriba o hacia abajo.

Por ejemplo, si tenemos 5.52, Excel nos redondea hacia arriba, y si tenemos 5.49 nos redondea hacia abajo:

=REDONDEAR(5,52;0)

El último parámetro indica el número de decimales o enteremos que necesitamos luego de la coma, pero pueden ser 1, 2, Etc.

Redondear a la decena más cercana.

Excel no solo aproxima o redondea decimales sino números enteros, que en este caso es la decena más cercana.

Por ejemplo tenemos 1.523  necesitamos redondearla a 1.520, que es la decena más cercana, lo que hacemos con la siguiente fórmula, suponiendo que el valor redondeado lo tenemos en A1:

=REDONDEAR(A1;-1)

Como se observa, el último parámetro es -1.

Redondear a la centena más cercana.

Si tenemos por ejemplo 23.676 y queremos redondearlo a la centena más cercana, es decir, a 23.700 utilizamos la siguiente fórmula:

=REDONDEAR(A1;-2)

El parámetro es negativo, es decir -2 cuando se quiere redondear centenas.

Redondear a la unidad de mil más cercana.

Si lo que queremos es redondear a la unidad de mil más cercana, como por ejemplo 24.570 a 25.000, utilizamos la siguiente fórmula:

=REDONDEAR(A1;-3)

El último parámetro es -3, y así seguimos a -4 para la decena de mil más cercana, etc.

Redondear siempre hacia arriba o hacia abajo.

La función Redondear solita redondea hacia arriba los valores de la mitad hacia arriba, incluyendo la mitad, y hacia abajo los valores menores a la mitad (50%)

Ejemplo: 5.5 siempre será redondeado hacia 6, es decir hacia arriba. Y 5.49 será redondeado siempre hacia abajo, es decir a 5.

Para controlar ese redondeo utilizamos REDONDEAR.MAS y REDONDEAR.MENOS, así:

=REDONDEAR.MAS(5.2;0)

Con ello siempre redondeará hacia arriba, es decir, a 6, y lo mismo si queremos redondear hacia abajo con .MENOS

Controlar el redondeo o aproximación en Excel.

Pero hay casos en que necesitamos tener un control más personalizado de la forma en que Excel redondea o aproxima los valores, y .MAS o .MENOS no es suficiente.

Como ya señalamos, por defecto, Excel redondea o aproxima al valor superior si el resultado real es igual o superior a la mitad; si el resultado es 0,5 aproxima a 1, si el valor es 0,4 aproxima a 0, si el valor es 0,6 aproxima 1.

La siguiente fórmula nos permite condicionar la aproximación de valores, de tal forma que, si el resultado es igual o inferior a 0,6, se aproximará al entero inferior, de lo contrario lo aproximará al entero superior.

=SI((A1-ENTERO(A1))<= 0,6;REDONDEAR.MENOS(A1;0);REDONDEAR.MAS(A1;0))

Así, si tenemos 5,6, el se aproximará a 5. Si tenemos 124,5, se aproximará a 124. Si el valor es 1.567,8 se aproximará a 1.568.

Esto nos da una idea de cómo manipular los resultados en Excel según nuestras necesidades. Es cuestión de experimentar, de probar. Nos sorprenderá el inmenso potencial que tiene Excel.

Recomendados.

Compártalo en Facebook Compártalo en Twitter

Déjenos su opinión

Una opinión
  1. Juliopr261 Dice:

    Gracias por el control del redondeo fue de mucha ayuda 🙂

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.