Condicionando rangos en Excel

Por

Cuanto se trabaja con Excel en ocasione es necesario condicionar diferentes rangos, de manera tal que el valor o la variable a considerar debe estar dentro de un rango definido, específico.

Los rangos pueden ser mayor a X, menor a X, mayor a X pero menor a Y, rangos que se pueden definir fácilmente con fórmulas.

Cuando el rango está condicionado a un solo límite, la fórmula es muy sencilla. Por ejemplo, si la condición para una operación es que el valor de la celda A1 sea mayor a 100, la fórmula sería:

=SI(A1>100;"X"; "")

Ahí le estamos diciendo a Excel que si A1 es mayor a 100 escriba la letra X  y si no que deje la celda vacía. Para cambiar la condición bastará con cambiar el signo > por < o por =, según se requiera.

Cuando el rango está condicionado por dos limites, la fórmula es un poco más compleja.

Supongamos que el valor de la celda A1 debe ser mayor a 500 y menor a 1.000 para que se realice determinada tarea. La fórmula sería así:

=SI(Y(A1>500;A1<1000);"A";"")

Ahora compliquemos más la situación. Supongamos que ahora necesitaremos que el valor de la celda A1 sea igual o superior a 500 e igual o inferior a 1.000. En este caso, en realidad estamos hablando de 4 condiciones, ya que debe ser igual o mayor a 500, e igual o menor 1.000. Bien, la formula sería así:

=SI(A1>=500;SI( A1<=1000;"X";""))

Con estas condicionales se pueden hacer multitud de operaciones mucho más complejas que escribir una simple X o dejar en blanco la celda; es cuestión de ser creativo según sean nuestras necesidades.

No hay que olvidar que en algunos computadores los separadores no son punto y coma, sino una coma, por lo que habrá que hacer el ajuste a las fórmulas si es que su computador opera con una coma.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

3 Opiniones
  1. ANAHI Dice:

    buenas tardes necesito ayuda con una formula para excel
    la consigna es:

    si el valor, es inferior a 15000 recibe 1000,
    si es <=15001 y <=20000 recibe 1500,
    si es <=20001 y <=30000 recibe 2000.
    si es inferior a 15000 recibe 2500

    lo que pude hacer es cada una de ella x separado en cada columna
    pero yo necesito que todas esten juntas que analice el valor de una sola celda y determine q le corresponde
    si alguien me puede ayudar!!
    desde ya muchas gracias!!

    Responder
    • Michael Alan Sanchez Dice:

      Cordial Saludo,
      Mira genera una lista las condiciones y formulas con el Buscar V pero con el 1 al final para que te busque por rangos
      es la menra mas facil de hacerlo.
      o escríbenos en el facebook por @Elgustodeaprender pagina Lo quenecesitas.

      Responder
  2. Monse Pecero Dice:

    Hola

    Necesito de su ayuda tengo que sacar el tiempo de retardo de una hoja de excel el problema es que hay compañeros que entran a las 8:30 y 9:00 am entonces necesito poder definir que tiempo de retraso hay entre la 8:30 y su hora de llegada asi como también los de las 9:00 y su hora de llegada pero a la quincena

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.