Condicionando rangos de datos o valores en Excel

Cuanto se trabaja con Excel en ocasione es necesario condicionar diferentes rangos de datos, de manera tal que el valor o la variable a considerar debe estar dentro de un rango definido, específico.

Rangos de datos en Excel.

Los rangos pueden ser mayor a X, menor a X, mayor a X pero menor a Y, rangos que se pueden definir fácilmente con fórmulas.

Cuando el rango está condicionado a un solo límite, la fórmula es muy sencilla. Por ejemplo, si la condición para una operación es que el valor de la celda A1 sea mayor a 100, la fórmula sería:

=SI(A1>100;"X"; "")

Ahí le estamos diciendo a Excel que si A1 es mayor a 100 escriba la letra X  y si no que deje la celda vacía. Para cambiar la condición bastará con cambiar el signo > por < o por =, según se requiera.

Cuando el rango está condicionado por dos limites, la fórmula es un poco más compleja.

Supongamos que el valor de la celda A1 debe ser mayor a 500 y menor a 1.000 para que se realice determinada tarea. La fórmula sería así:

=SI(Y(A1>500;A1<1000);"A";"")

Ahora compliquemos más la situación. Supongamos que ahora necesitaremos que el valor de la celda A1 sea igual o superior a 500 e igual o inferior a 1.000. En este caso, en realidad estamos hablando de 4 condiciones, ya que debe ser igual o mayor a 500, e igual o menor 1.000. Bien, la formula sería así:

=SI(A1>=500;SI( A1<=1000;"X";""))

Con estas condicionales se pueden hacer multitud de operaciones mucho más complejas que escribir una simple X o dejar en blanco la celda; es cuestión de ser creativo según sean nuestras necesidades.

No hay que olvidar que en algunos computadores los separadores no son punto y coma, sino una coma, por lo que habrá que hacer el ajuste a las fórmulas si es que su computador opera con una coma.

Forma de citar este artículo (APA):

Gerencie.com. (2009, septiembre 17). Condicionando rangos de datos o valores en Excel [Entrada de blog]. Recuperado de https://www.gerencie.com/condicionando-rangos-en-excel.html

Recomendados.

Compártalo en Facebook Compártalo en Twitter Compártalo en Whatsapp
Deje su opinión o su pregunta.

Regístrese para informarle cuando se responda su pregunta.

  1. iris (enero 31 de 2022)

    hola buenas tardes, tengo problemas para encontrar una formula que me arroje el mismo dato si cumple la condición que puse, ejem. si en a1 se encuentra un dato menor que 0, quiero que en c1 me aparezca ese dato, osea si dice -10, que en la otra celda me aparezca -10

    Responder
  2. MARTIN (febrero 4 de 2022)

    Que tal espero se encuentren muy bien.
    Podrían ayudarme para resolver mi problema, quiero condicionar la siguiente tabla y obtener el valor de la celda turno. Al yo colocar una hora que en automático me condicione a que turno pertenece.

    FECHA HORA CHECKPOINT TURNO
    01/01/2022 02:17 BB5C38 ¿?

    Tabla de turnos.
    HORA INICIO HORA FIN TURNO

    06:01 14:00 MAÑANA
    14:01 22:00 TARDE
    22:01 06:00 NOCHE

    Responder
    • ARMANDO en respuesta a MARTIN (febrero 10 de 2022)

      Estoy con la misma situacion, podrian ayudarnos

      Responder
  3. Alejandro Pérez (febrero 28 de 2022)

    Buen día podrían apoyarme con una fórmula:

    Necesito que diga
    .26 ó = 1 GRADO C

    Gracias por apoyar

    Responder
  4. ALEX (febrero 28 de 2022)

    Buen día podrían apoyarme con una fórmula:

    Necesito que diga
    .26 ó = 1 GRADO C

    Gracias por apoyar

    Responder
  5. nelson (noviembre 10 de 2022)

    SEÑORES,GRACIAS POR QUIEN PUEDA COLABORARME: TENGO EL SIGUIENTE PROBLEMA Y NECESITO RESULTADO SIN MACROS: NECESITO SUMAR Y PASAR PRODUCTOS DE VENTAS UN MISMO CODIGO DE FILAS, PASARLOS A A UNA SOLA FILA Y CADA UNO EN SU DIA DE FECHA CORRESPONDIENTE EN COLUMNAS, SIN UTILIZAR TRANSPONER. [email protected]

    Responder

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.