Condicionando rangos en Excel

Por 18 septiembre, 2017

Cuanto se trabaja con Excel en ocasione es necesario condicionar diferentes rangos, de manera tal que el valor o la variable a considerar debe estar dentro de un rango definido, específico.

Los rangos pueden ser mayor a X, menor a X, mayor a X pero menor a Y, rangos que se pueden definir fácilmente con fórmulas.

Cuando el rango está condicionado a un solo límite, la fórmula es muy sencilla. Por ejemplo, si la condición para una operación es que el valor de la celda A1 sea mayor a 100, la fórmula sería:

=SI(A1>100;"X"; "")

Ahí le estamos diciendo a Excel que si A1 es mayor a 100 escriba la letra X  y si no que deje la celda vacía. Para cambiar la condición bastará con cambiar el signo > por < o por =, según se requiera.

Cuando el rango está condicionado por dos limites, la fórmula es un poco más compleja.

Supongamos que el valor de la celda A1 debe ser mayor a 500 y menor a 1.000 para que se realice determinada tarea. La fórmula sería así:

=SI(Y(A1>500;A1<1000);"A";"")

Ahora compliquemos más la situación. Supongamos que ahora necesitaremos que el valor de la celda A1 sea igual o superior a 500 e igual o inferior a 1.000. En este caso, en realidad estamos hablando de 4 condiciones, ya que debe ser igual o mayor a 500, e igual o menor 1.000. Bien, la formula sería así:

=SI(A1>=500;SI( A1<=1000;"X";""))

Con estas condicionales se pueden hacer multitud de operaciones mucho más complejas que escribir una simple X o dejar en blanco la celda; es cuestión de ser creativo según sean nuestras necesidades.

No hay que olvidar que en algunos computadores los separadores no son punto y coma, sino una coma, por lo que habrá que hacer el ajuste a las fórmulas si es que su computador opera con una coma.

Temas relacionados

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

11 Opiniones
  1. ANAHI Dice:

    buenas tardes necesito ayuda con una formula para excel
    la consigna es:

    si el valor, es inferior a 15000 recibe 1000,
    si es <=15001 y <=20000 recibe 1500,
    si es <=20001 y <=30000 recibe 2000.
    si es inferior a 15000 recibe 2500

    lo que pude hacer es cada una de ella x separado en cada columna
    pero yo necesito que todas esten juntas que analice el valor de una sola celda y determine q le corresponde
    si alguien me puede ayudar!!
    desde ya muchas gracias!!

    Responder
    • Michael Alan Sanchez Dice:

      Cordial Saludo,
      Mira genera una lista las condiciones y formulas con el Buscar V pero con el 1 al final para que te busque por rangos
      es la menra mas facil de hacerlo.
      o escríbenos en el facebook por @Elgustodeaprender pagina Lo quenecesitas.

      Responder
    • Mario Alvarez Dice:

      Anahí, de entrada tu planteamiento pareciera estar equivocado entre las condiciones de >= y <=, pero buscando entender como quieres utilizar tu formula busque un ejemplo poniéndolo en un vendedor al cual se le darán comisiones en base a su venta, si vende "=”(mayor o igual) a 15,001 y “=”(mayor o igual) a 20,001 y “<="(menor o igual) a 30,000 le darás 2,000 y si vende mas de 30,000 le darás 2,500
      si esto es correcto tu formula seria (suponiendo que el valor de la venta este en la celda "C4")

      =SI(C4<=15000,1000,SI(C4<=20000,1500,SI(C4<=30000,2000,2500)))

      Espero que esto te sirva y puedas acoplarlo en tu trabajo…

      saludos…

      Responder
  2. Monse Pecero Dice:

    Hola

    Necesito de su ayuda tengo que sacar el tiempo de retardo de una hoja de excel el problema es que hay compañeros que entran a las 8:30 y 9:00 am entonces necesito poder definir que tiempo de retraso hay entre la 8:30 y su hora de llegada asi como también los de las 9:00 y su hora de llegada pero a la quincena

    Responder
  3. Carosanro Dice:

    Buenas tardes, requiero realizar el calculo de mis comimsiones, el cual tiene varios rangos. Ya logré hacer la formula pero necesito que el resultado si es positivo me arroje la multiplicación de la venta por el % de comisión.

    =SI(L31>=60%;SI(L31<=74,99%;"(H31*R28)";"0"))

    Actualmente si es positivo me sale la multiplicación mas no el resultado.

    Responder
    • Pedro Rosario Dice:

      Debes quitarle las comillas a la expresión (H*R)

      Responder
  4. Mariely Dice:

    Buenas tardes, requiero calcular una condicional en base a dos rangos previamente ya calculados en base a datos ingresados.
    Los rangos son pesos maximos y minimos que deben tener las aves. que son 250 y 316 (estos ya lo calcule con otra formula). En la base de datos de peso de 200 aves clasificados en 10 grupos de 20, necesito conocer y que me marque con (+) todos los pesos que sean mayores a 316, y con (-) los menores a 250. si estan entre 250 y 316 que los deje en blanco. Necesito esta condicional para luego hacer en otro calculo que me sume cuantos positivos y negativos hay en toda la base de datos de 200 pesos. si me pueden colaborar por favor. Gracias de antemano.

    Responder
  5. Omar Dice:

    Hola!
    Necesito ayuda con el siguiente planteamiento, quiero automatizar estos valores, es decir si algo me cuesta 150, que me arroje 1.500, si cuesta 550, sea igual a 3.000

    0-199 =1500
    200-299 =2000
    300-399 =2500
    400-499 =3000
    500-599 =3500
    600-699 =4000
    700-799 =4500

    Gracias de antemano

    Responder
    • Pedro Rosario Dice:

      Supondremos que el valor estará en la celda C5. Entonces escribimos,

      =si(C5<=199,1500,si(C5<=299,2000,si(C5<=399,2500,si(C5<=499,3000,si(C5<=599,3500,si(C5<=699,4000,4500))))))

      Responder
  6. Pedro Rosario Dice:

    Saludos. Quisiera que me dijeran la forma de conseguir que el valor se ponga rojo cuando sobrepase el límite establecido.
    Gracias.

    Responder
  7. Miguel Angel Dice:

    Hola buen dia, quisiera saber de que forma puedo implementar una formula tomando en cuanto que tengo un punto de comparación; pero al mismo tiempo que el valor se compare con un rango de celdas y cuando la sumatoria de este rango de celdas ya exceda el punto de comparación ya no permitir ingresar valores en las demás celdas

    Ej.

    Punto de comparación A1=85
    Rango de Celdas donde se deben ingresar valores [B1, C1, D1, E1 & F1] donde la suma de todas estas celdas no debe ser mayor a A1

    puede ser

    B1= 5
    C1= 30
    D1= 40
    E1= 10
    F1= 0

    pero condicionar si ya hemos llegado al punto de comparación

    B1= 5
    C1= 70
    D1= 0 No permitir ingresar valor ya que se esta cumpliendo el total del punto de comparación A1
    E1= 10
    F1= 0 No permitir ingresar valor ya que se esta cumpliendo el total del punto de comparación A1

    Espero poder contar con su ayuda

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.

¿Preocupado por su pensión?