Numerar celdas o datos en rangos discontinuos en Excel

Por

En algunos casos se requiere numerar celdas o datos en rangos de datos que son discontinuos debido a la existencia de celdas o filas vacías o sin datos, de manera que no se puede completar una determinada secuencia de numeración.

Cuando el rango de datos continuos termina por la presencia de una celda o fila sin datos, es preciso iniciar el conteo nuevamente, puesto que estamos ante un nuevo rango.

Es el caso del siguiente ejemplo:

Departamento Empleado

#

Costos Carlos Piñuela

1

Miriam Prada

2

Angélica García

3

Cartera Fernando Cuervo

1

Pedro Buendía

2

Alejandra Murcia

3

Ventas Adriana Pastrana

1

Yurany Moreno

2

Lina Mayorga

3

Alberto Quiroga

4

Contabilidad Angie Corrales

1

Juan Carlos Villa

2

Aminta Cortés

3

Administración Adalberto Burbano

1

Paola Núñez

2

Necesitamos numerar los empleados de cada departamento, y si son muchos hay que hacerlo mediante fórmulas de tal manera que sólo se escribe la primera y luego se arrastra hacia abajo tantas filas como sea necesario.

Pues bien, la fórmula que hace ese trabajo es la siguiente:

=SI(B2="";"";CONTAR.SI(B2;"<>")+MAX(0;C1))

Para que el rango se suspenda una vez se encuentra una celda vacía, creamos al función condicional SI, de tal manera que al encontrar una celda vacía el resultado será una celda vacía (“”).

Luego le indicamos a Excel con la función CONTAR.SI  que cuente las celdas que no estén vacías (“<>”) y utilizamos la función MAX para sumar el valor correspondiente al rango anterior y crear así la numeración consecutiva correspondiente.

Descargar ejemplo.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

3 Opiniones
  1. SVE Dice:

    Muchas gracias, me sirvió la formula, gracias por compartir la información.

    Responder
  2. Miguel Dice:

    Gracias!

    Responder
  3. Jeferson Dice:

    Buenas noches, excelente ayuda!

    Consulta como seria en el caso que tienes registros de tres personas segun tres turnos. En cada turno cada persona registra n actividades que segun un formato estas se van enumerando por ejemplo:

    JUAN-01
    JUAN-02
    JUAN-03 aqui termina la ultima actividad del turno 1
    PEDRO-01
    PEDRO-02 aqui termina la ultima actividad del turno 2
    MARIA-01
    MARIA-02
    MARIA-03 aqui termina la ultima actividad del turno 3

    Y todos los registros van seguidos sin dejar una fila vacia.

    Saludos,

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.

¿Preocupado por su pensión? Manténgase Informado.