Crear rangos dinámicos en Excel

Por 17 marzo, 2019

En esta oportunidad explicaremos cómo crear rangos dinámicos en Excel, ya sea un único rango o múltiples rangos dinámicos en una sola hoja.

En primer lugar le invitamos a consultar qué es un rango dinámico, y una vez comprendido el concepto, procedemos a crearlos. Igualmente es importante tener nociones sobre la función DESREF, que se utilizará para el propósito que nos ocupa.

¿Qué son los rangos dinámicos en Excel?

Los rangos dinámicos en Excel nos permiten agregar o eliminar datos sin que estos se queden por fuera del rango, pues al ser dinámico, se va ajustando a la cantidad de datos ingresados.

Supongamos que tenemos una lista en el rango A1:A20, pero si eliminamos o agregamos más empleados, tenemos que ajustar manualmente se rengo para que se ajuste a la nueva cantidad de datos.

Supongamos que debemos la siguiente fórmula para buscar empleados:

=BUSCARV("Pedro";A1:B20;2)

Debemos buscar a Pedro en el rango de empleados que hay de A1:B20. ¿Pero qué pasa si agregamos 10 empleados?, pues tenderemos que adaptar la fórmula así:

=BUSCARV("Pedro";A1:B30;2)

Y cada vez que se agreguen empleados hay que cambiar el rango indicado de la fórmula.

Esto lo evitamos si en lugar de colocar el rango en la formula, le asignamos un nombre de rango a las celdas que contienen los datos de interés, y le podemos colocar como nombre Empleados, y de esa forma nos queda así:

=BUSCARV("Pedro";Empleados;2)

Ahora hacemos que se rango sea dinámico como a continuación se explica.

Crear nombres para rangos dinámicos.

Para crear un rango dinámico, formulamos las referencias y con ello definimos un nombre para nuestro rango dinámico.

Para ello, en la barra de herramientas buscamos la opción “Fórmulas y luego “Asignar un nombre al rango”.

Le damos el nombre a nuestro rango y seleccionamos la hoja del libro a la que pertenece ese rango.

Seguidamente introducimos la fórmula que definirá nuestro rango dinámico.

Si queremos un rango dinámico infinito hacia abajo y hacia la derecha, esto es que se puedan agregar tantas filas como columnas, la fórmula a introducir será:

=DESREF($A$1;0;0;CONTARA($A:$A);CONTARA($1:$1))

Con ello le estamos diciendo a Excel que defina el rango considerando todas las celdas con valores que estén por debajo de la celda A1 y desde la columna A hacia la derecha.

Pero seguramente necesitamos un rango dinámico  limitado, como por ejemplo que ocupe únicamente la columna A desde la fila 2. En ese caso la  fórmula será:

=DESREF($A$1;1;0;CONTARA($A:$A))

Para la columna B la fórmula será:

=DESREF(B$2;1;0;CONTARA($B:$B))

Si queremos un rango dinámico que ocupe las columnas  E y F, que vaya de a fila 12 a la 100,  la fórmula será:

=DESREF($E$12;0;0; CONTARA($E1:$E$100 ); 2)

Descargar anexo

Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.

Propiedad horizontal