Comparar dos columnas en Excel

Por   07/05/2013

De gran utilidad es hacer comparaciones entre dos columnas en Excel para saber si comparten dato, y si es así, qué datos comparte, o qué datos no compartes.

Por ejemplo, es probable que necesitemos saber qué datos están en la columna A y en la B, o qué datos están la columna B que no estén en la columna A. Para determinarlo, es preciso hacer una comparación entre las dos columnas.

Supongamos los siguientes datos:

Bogotá Barranquilla
Medellín Armenia
Pereira Bucaramanga
Cali Bogotá
Manizales Cali
Popayán Ibagué

Para extraer los valores que se repiten utilizamos la siguiente fórmula:

=SI(CONTAR.SI($A$1:$A$6;B1)>0;B1;0)

Luego arrastramos hacia abajo hasta cubrir el rango completo.

El resultado será:

Bogotá Barranquilla

0

Medellín Armenia

0

Pereira Bucaramanga

0

Cali Bogotá Bogotá
Manizales Cali Cali
Popayán Ibagué

0

La fórmula nos dice que Bogotá y Cali se repiten, es decir que están en las dos columnas.

Si queremos saber que valores no se repiten, esto es, que valores son únicos, que están sólo en una de las dos columnas, la fórmula será:

=SI(CONTAR.SI($A$1:$A$6;B1)>0;0;B1)

Igualmente arrastramos la fórmula hacia abajo para cubrir todo el rango. El resultado es:

Bogotá Barranquilla

0

Medellín Armenia Armenia
Pereira Bucaramanga Bucaramanga
Cali Bogotá

0

Manizales Cali

0

Popayán Ibagué Ibagué

Obsérvese que solamente se ha cambiado la última parte de la fórmula “>0;0;B1”, donde B1 pasa al final, para indicar que si no coincide con A muestre el resultado de B1.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.