Separar valores negativos y positivos en Excel

Por petición de nuestros usurarios, expondremos cómo hacer para extraer o separar valores negativos y positivos en Excel.

Es posible que en una base de datos existan valores negativos y positivos, y en ocasiones podemos necesitar separarlos para una mejor identificación y análisis.

Supongamos que tenemos una serie de datos en la columna A desde la fila 2, es decir, dese A2.

Para separar los valores positivos y negativos, necesitaremos de dos columnas más, una para colocar los valores positivos y otra para colocar los valores negativos, así que las fórmulas las colocaremos en las columnas B y C.

Para separar los valores, utilizaremos la función SUMAR.SI condicionada, y la condición será que el valor buscado en el rango señalado sea negativo o positivo, o mayor o menor a cualquier otro valor, por lo que son muchas las variantes que se pueden utilizar dependiendo de las necesidades del usuario.

En este caso vamos a suponer que los valores a separar están ubicados en la columna A desde la fila 2 hasta la fila 10.000 [A1:A10000].

La formula será la siguiente:

=SI(SUMAR.SI($A$2:$A$10000;A2)>0;A2;"")

Observemos que las referencias son absolutas, por eso se encierran entre signos $, de esta forma le decimos a Excel que el rango a buscar o revisar será siempre el mismo no importa en qué celda se ubique la fórmula.

Esta fórmula la pegamos en la celda B2 o C2 y luego se arrastra hasta la última fila en que haya valores, que en este caso sería hasta la fila 10000.

La formula aquí escrita separa los valores positivos; para separar valores negativos basta con cambiar la condición, esto es cambiar >0 por <0.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.

Siéntase libre de opinar

2 Opiniones
  1. Bucio60 dice:

    hola, buen dia me gustaria saber como comparar un dato que cumpla los siguientes criterios ej.

    requiero colocar un contador pero necesito identifica si un dato es mayor que x pero menor que y, al cumplir la condicion verdadera hara colocar un contador de ser negativo dara un dato nulo.

    la formula que creo espresa mi condicion seria esta X<A<Y, el problema es que no se como hacer que haga esta doble validacion, puesto que me toma el dato por elementos, no como una sola operacion

    un ejemplo seria asi

    1 <2<3 de ser afirmativo deberia sol funcionar con el numero 2 el problema es que me indentifica el uno tambien como afirmativo obvio por ser menor a 3, pero no se como ubicar el dato de enmedio como el condicional

  2. Nolberto Reymundo Torres Marin dice:

    buenos dias

    tengo una columna con numeros en positivo y negativo(I3) y deseo separara otra columna (k3) solo los valores negativos.

    alguien podria asesorarme.
    gracias.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.