Fórmula para quitar decimales en Excel

Para eliminar los decimales de un resultado en una celda existen distintas fórmulas con resultados distintos según necesitemos, como las funciones REDODNEAR, TRUNCAR Y ENTERO.

Eliminar los decimales en Excel.

Los decimales en Excel se pueden ocultar mediante la opción formato de la celda, pero dicha solución sólo los oculta visualmente, por lo que se seguirán haciendo cálculos con los decimales, y lo que se requiere es que el decimal desaparezca y sólo queden números enteros y se hagan operaciones que reconozcan el número entero, esto es, que no tengan en cuenta los decimales.

Como señalamos al inicio, esto se puede lograr con las funciones REDODNEAR, TRUNCAR Y ENTERO, que según lo que necesitemos en un momento dado.

Estas fórmulas pueden parecer similares, pero no siempre es así como pasamos a explicarlo.

Eliminar decimales con TRUNCAR.

La función TRUNCAR elimina los decimales de un número, simplemente truncando o cortando los dígitos decimales sin redondear.

TRUNCAR no realiza ningún redondeo y siempre devuelve el número sin decimales.

Por ejemplo, si aplicas TRUNCAR a 3.75, obtendrás 3. Esto significa que los decimales se eliminan sin importar si son mayores o menores a 0.

La fórmula funciona así:

=TRUNCAR(A1)

En este caso el número al que se eliminarán los decimales está en al celda A1, pero también se puede hacer de forma directa así:

=TRUNCAR(3;75)

Eliminar decimales con REDONDEAR.

Esta función tiene dos características:

  1. Permite controlar el número de decimales que queremos eliminar.
  2. Redondea hacia el valor el entero más cercano, ya sea hacia arriba o hacia abajo.

Por ejemplo, =REDONDEAR(3.75; 0)  dará 4, ya que redondea 3.75 al entero más cercano que en este caso es 4. =REDONDEAR(3.25; 0)  dará 3 que es el entero más cercano.

Además, me permite definir cuantos decimales quiero eliminar con el segundo argumento.

Por ejemplo, si tengo 3.8756 puedo decirle que sólo deje 2 decimales:

=REDONDEAR(A1;2)

La función REDONDEAR tiene dos variaciones que permiten definir hacia donde quiero redondear, si hacia arriba o hacia abajo:

REDONDEAR.MAS y REDONDEAR.MENOS

Así, =REDONDEAR.MAS(4.18;0) dará como resultado 5 ya que es el valor superior al decimal. =REDONDEAR.MENOS(4.98;2) dará como resultado 4, que es el entero inferior más cercano.

Eliminar decimales con ENTERO.

La función ENTERO redondea un número hacia abajo al entero más cercano, descartando los decimales.

ENTERO siempre redondea hacia el número entero más bajo, sin importar si los decimales se aceran más hacia arriba o hacia abajo.

Por ejemplo, =ENTERO(3.75) dará 3, ya que descarta los decimales y redondea hacia abajo.

En valores positivos el resultado de utilizar ENTERO y TRUNCAR es el mismo, pero no así cuando se trabajan valores negativos donde se ve claramente la diferencia y la importancia de utilizar uno u otro.

Supongamos que tenemos el número -3.9.

TRUNCAR(-3.9) dará como resultado -3, ya que elimina los decimales sin importar el signo del número.

ENTERO(-3.9) dará como resultado -4, ya que redondea hacia abajo al número entero más cercano, que en este caso es -4.

En este caso, TRUNCAR y ENTERO generan resultados diferentes debido a cómo tratan los números negativos. TRUNCAR simplemente elimina los decimales, mientras que ENTERO redondea hacia abajo al número entero más bajo independientemente del signo.

Forma de citar este artículo (APA):

Gerencie.com. (2023, octubre 28). Fórmula para quitar decimales en Excel [Entrada de blog]. Recuperado de https://www.gerencie.com/formula-para-quitar-decimales-en-excel.html

Recomendados.

Compártalo en Facebook Compártalo en Twitter
Deje su opinión o su pregunta.

Regístrese para informarle cuando se responda su pregunta.

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.