Dividir por cero correctamente en Excel

Dividir en Excel por cero nos genera un error que además de ser poco estético, impide que el resto de formulas funcionen correctamente.

Siembre que tratamos de dividir por cero tendremos como resultado el siguiente valor: #¡DIV/0!, error que se repetirá en todas las formulas que vinculen esta celda.

No siempre se puede evitar tener que dividir por un cero, así que es caso de ser obligatorio, hay que evitar que Excel nos genere ese error.

Para ello utilizaremos una fórmula condicional, de modo que condicionaremos la división a que si determinada celda está en cero no divida sino que coloque cero, pero si su valor es diferente de cero, realice la división correspondiente.

Supongamos las celdas A1 y B1 que debemos dividir y colocar el resultado en C1.

En C1 colocaremos la siguiente fórmula:

=SI(Y(A1>0;B1>0);A1/BC1;0)

Lo que hace esta fórmula es decirle a Excel que si tanto A1 como B1 son mayores que cero haga la división, de lo contrario coloque cero.

Podríamos también hacer lo contrario, es decir, si A1 y B1 son iguales a cero, no divida y en su lugar coloque cero, pero si no que realice la operación. En ese caso la fórmula sería:

=SI(Y(B10=0;C10=0);0;B10/C10)

Con esta segunda formula Excel dividirá si los valores son diferentes a cero, incluyendo tanto los mayores a cero como los menores a cero.

Mediante la función SI(Y  se pueden condicionar un gran número de variables según sean las necesidades de cada situación.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.