Evitar el famoso error #¡DIV/0! en Excel

Cuando se hacen operaciones en Excel, especialmente donde es necesario dividir y alguna de las celdas está vacía o tiene un valor cero, se presenta un error muy poco estético: #¡DIV/0!

Este error se puede evitar de una forma muy sencilla, aplicando una sola condicional.

Supongamos que tenemos valores en las columnas A y B, y que debemos dividir los valores de las columnas A por los valores de la columna B.

La fórmula para hacer esa división es básica: =A1/B1, sólo que si alguna celda de la columna B está vacía o tiene valor cero, nos presentará este feo error, así que la cambiamos por la fórmula siguiente,.
=SI(ESERROR(A1/B1);0;A1/B1)

La función ESERROR se puede aplicar a cualquier fórmula, por complicada que sea, para solventar este error.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

4 Opiniones
  1. David Star dice:

    Probé varias de las fórmulas sugeridas en este sitio pero ninguna sirvió (Excel 2010). Lo que logré fué esto: =SI(ESNUMERO(A1),PROMEDIO(A1:D1),””)
    PROPOSITO: Si quiero promediar desde A1 hasta D1,y evitar el #DIVX/0, entonces esta fórmula me dará un resultado vacío si NO hay número en A1, y si hay número en A1 me calculará el promedio.

  2. Francisco Vásquez dice:

    Te pasaste, muchas gracias. Estoy en mi práctica industrial en una pequeña industria que mueve su EE.RR. sólo con Excel, y estaba muy mal organizado, y con el EE.RR. que cree yo, más tu ayuda al quitar ese fucking error, quedó perfecto.
    OJO, LEI COMENTARIOS QUE AL PARECER NO LES FUNCIONABA EN EXCEL 2010 O 2013, A MI ME FUNCIONA EXCELENTE PARA EXCEL 2016

  3. maria dice:

    Buenos días. Tengo el erro #¡DIV/0! y necesito quitarlo. El único inconveniente es que en esta misma celda hay dos fórmulas, es decir, tengo que restar dos casillas que están a 0 por lo pronto y el resultado de la resta tengo que dividirlo por una de las casillas. Y se que puedo hacer con una fórmula pero con dos no sé.

  4. maria dice:

    Buenos días. Tengo el erro #¡DIV/0! y necesito quitarlo. El único inconveniente es que en esta misma celda hay dos fórmulas, es decir, tengo que restar dos casillas que están a 0 por lo pronto y el resultado de la resta tengo que dividirlo por una de las casillas. Y se que puedo hacer con una fórmula pero con dos no sé.

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.