Evitar el error #¡DIV/0! en Excel

Cuando se hacen operaciones en Excel, especialmente donde es necesario dividir y alguna de las celdas está vacía o tiene un valor cero, se presenta un error muy poco estético: #¡DIV/0!

Cómo hacer para que no salga #¡DIV/0!en Excel

En primer lugar, el error se evita al formular correctamente en Excel, es decir, evitar las condiciones que generan el error, como por ejemplo dividir entre cero.

El error en sí no se trata de evitar, sino de que aparezca o se muestre, y eso se puede lograr recurriendo a una condicional.

Supongamos que tenemos valores en las columnas A y B, y que debemos dividir los valores de las columnas A por los valores de la columna B.

La fórmula para hacer esa división es básica: =A1/B1, sólo que, si alguna celda de la columna B está vacía o tiene valor cero, nos presentará este error #¡DIV/0!, así que la cambiamos por la fórmula siguiente:

=SI.ERROR(A1/B1;0)

Incluso en lugar de mostrar un cero, podemos dejar vació cambiando el último parámetro así:

=SI.ERROR(A1/B1;"")

Y se puede hacer que en lugar de cero o de nada, se muestra un texto así:

=SI.ERROR(A1/B1;"Revisar fórmula")

Y para dar respuesta a un usuario, pare evitar un error al aplicar un promedio a un rango sin valores, se aplica la siguiente fórmula:

=SI.ERROR(PROMEDIO(A2:A5);0)

La función SI.ERROR  se puede aplicar a cualquier fórmula, por complicada que sea, para solventar este error.

Forma de citar este artículo (APA):

Gerencie.com. (2009, enero 4). Evitar el error #¡DIV/0! en Excel [Entrada de blog]. Recuperado de https://www.gerencie.com/evitar-el-famoso-error-div0-en-excel.html

Recomendados.

Compártalo en Facebook Compártalo en Twitter Compártalo en Whatsapp
Deje su opinión o su pregunta.

Regístrese para informarle cuando se responda su pregunta.

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.