Sumar valores dentro de un rango de fechas en Excel

En el anterior documento explicamos cómo sumar valores de una fecha específica; en esta oportunidad explicaremos como sumar valores que se encentran en un rango de fechas, es decir entre una fecha y otra.

Sumar valores que se encuentren en un rango de fechas.

Supongamos que necesitamos averiguar cuanto suman las facturas emitidas entre el 10 de julio de 2019 y el 22 de agosto de 2019. Podríamos utilizar un filtro, pero tal vez sea más cómoda una sencilla fórmula.

Al igual que en el supuesto del documento anterior, supongamos que la fecha de las facturas está en la columna A desde la fila 1 hasta la 1.000 y que el valor de las facturas está en la columna B desde la fila 1 hasta la 1.000.

Como se trata de una suma condicionada a un rango de fechas, utilizamos la fórmula SUMAR.SI de la siguiente forma de acuerdo a nuestro supuesto:

=SUMAR.SI(A1:A500;">="&FECHA(2019;7;10);B1:B1000)-SUMAR.SI(A1:A500;">"&FECHA(2019;8;22);B1:B1000)

Esta fórmula está compuesta por dos partes. La primera parte suma los valores iguales o superiores a una fecha (la inferior). La segunda parte suma los valores superiores a otra fecha (la superior).

Luego la sumatoria de la segunda parte se resta a la sumatoria de la primera parte.

Explicación: Si tengo un rango de 1 a 100 y quiero saber cuánto hay de 15 a 30, una de las soluciones es sumar lo que hay entre 15 y 100 y luego restar lo que hay entre 31 y 100. De esta forma queda únicamente lo que hay entre 15 y 30. Es exactamente lo que hace la fórmula de arriba.

No sobra aclarar que en la primera parte de la formula se indica la fecha límite inferior y en la segunda la fecha límite superior.

Forma de citar este artículo (APA):

Gerencie.com. (2011, agosto 22). Sumar valores dentro de un rango de fechas en Excel [Entrada de blog]. Recuperado de https://www.gerencie.com/sumar-valores-dentro-de-un-rango-de-fechas-en-excel.html

Recomendados.

Deje su opinión o su pregunta.

Regístrese para informarle cuando se responda su pregunta.

  1. Marco Sanchez (marzo 31 de 2022)

    Gracias, ya aprendí como se hace.

    Responder
  2. Morgan Alen (octubre 29 de 2022)

    Muchas gracias! me sirvió mucho el código y la explicación

    Responder

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.