Sumar valores dentro de un rango de fechas en Excel

En el anterior documento explicamos cómo sumar valores de una fecha específica; en esta oportunidad explicaremos como sumar valores que se encentran en un rango de fechas, es decir entre una fecha y otra.

Supongamos que necesitamos averiguar cuando suman las facturas emitidas entre el 10 de julio de 2011 y el 22 de agosto de 2011. Podríamos utilizar un filtro, pero tal vez sea más cómoda una sencilla fórmula.

Al igual que en el supuesto del documento anterior, supongamos que la fecha de las facturas están en la columna A desde la fila 1 hasta la 1.000 y que el valor de la facturas está en la columna B desde la fila 1 hasta la 1.000.

Como se trata de una suma condicionada a un rango de fechas, utilizamos la fórmula SUMAR.SI de la siguiente forma de acuerdo a nuestro supuesto:

=SUMAR.SI(A1:A500;">="&FECHA(2011;7;10);B1:B1000)-SUMAR.SI(A1:A500;">"&FECHA(2011;8;22);B1:B1000)

Esta fórmula está compuesta por dos partes. La primera parte suma los valores iguales o superiores a una fecha (la inferior). La segunda parte suma los valores superiores a otra fecha (la superior). La sumatoria de la segunda parte se resta a la sumatoria de la primera parte.

Explicación: Si tengo un rango de 1 a 100 y quiero saber cuánto hay de 15 a 30, una de las soluciones es sumar lo que hay entre 15 y 100 y luego restar lo que hay entre 31 y 100. De esta forma me queda únicamente lo que hay entre 15 y 30. Es exactamente lo que hace la fórmula de arriba.

No sobra aclarar que en la primera parte de la formula se indica la fecha límite inferior y en la segunda la fecha límite superior.

Contenido relacionado:
Compartirlo
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

16 Opiniones
  1. José Aguero dice:

    Necesito sumar los valores de actividades por días en un mes.
    Tengo una serie de registros por funcionarios; necesito observar QUE DÍAS de la semana durante un mes la cantidad de actividades registradas, con la finalidad de saber que día de la semana hay menos o un alto desempeño.

    Gracias.

  2. Manuela dice:

    hola, tengo un problema, bueno varios problemas. trabajo en el back-office y quiero sacar la siguiente formula con los siguientes datos;

    – FECHA DE LA SOLICITUD
    – CLIENTE
    – EMPLEADO
    – CLIENTES APROBADOS/DENEGADOS
    – FECHA DE PAGO INCENTIVOS
    – PARAMETROS

    Bien, quisiera una fórmula que se cuente cada empleado los clientes que hayan sido aprobados, y que, aquí viene la cuestión:

    contar.si.conjunto: fecha de incentivos son un dia menos y un mes mas, teniendo en cuenta que los dias del mes pueden ser 28/29/30/31

    1º pregunta: como sacar el mes correspondiente de pago de incentivos? ejemplo
    FECHA SOLICITUD/ FECHA PAGO DE INCENTIVO/EMPLEADO/CLIENTE/CRUCE “OK” O “NO”
    05/03/2016 / 04/04/2016 /PEPITO / JUAN / OK
    CADA EMPLEADO TIENE SU FECHA DE ALTA ( HAY UNOS UNO 150)

    AL PONER “CONTAR SI CONJUNTO”
    RANGO 1. EMPLEADOS
    CRITERIO 1. PEPITO
    RANGO 2. CRUCE
    CRITERIO 2. OK
    RANGO 3. FECHAS DE LA SOLICITUD
    CRITERIO 3. FECHA DE LA SOLICITUD QUE HA REALIZADO EL EMPLEADO
    RANGO 4: FECHA DE PAGO DE INCENTIVO (DIA-1,MES+1,AÑO) Y AQUI ES DONDE DA ERROR

    QUIEN ME ENTIENDA Y ME SOLUCIONE EL PROBLEMA LE INVITO A UNA CERVEZA

  3. jhonny torres dice:

    buenos días tengo el siguiente problema…
    me mandaron hacer un cuadro donde tengo un producto que tiene una fecha de adquisición y una fecha de caducidad según 5,10 y 20 años que se quiere que cuando se coloque la fecha de adquisición me coloque automáticamente la de caducidad.. el cuadro es en excel me podrían ayudar por favor

    • Silvina dice:

      Jhonny, puedes hacer operaciones con las fechas, por ejemplo si tienes 1/1/2016 y quieres calcular 5 años, sumas a la fecha (365*5). Recuerda ponerle formato de fecha a la de destino o te dejará un número.

  4. ISC. ROBERTO FONSECA dice:

    Hola usando sus criterios encontre esta formula para sumar mediante fechas espero le sirva Saludos.

    =SUMAR.SI.CONJUNTO(OCTUBRE!E13:E21,OCTUBRE!M13:M21,”=”&FECHA(2016,11,1))

  5. ISC. ROBERTO FONSECA dice:

    =SUMAR.SI.CONJUNTO(OCTUBRE!E13:E21,OCTUBRE!M13:M21,”=”&FECHA(2016,11,1))

  6. ISC. ROBERTO FONSECA dice:

    “=SUMAR.SI.CONJUNTO(OCTUBRE!E13:E21,OCTUBRE!M13:M21,”=”&FECHA(2016,11,1))”

  7. ISC. ROBERTO FONSECA dice:

    No se por que no sale completa la formula jeje Si quieren pueden pedirla ami correo
    robfonseca1991@hotmail.com

  8. juver dice:

    Buenas,

    Quiero que Excel mes diga que del 01/01/16 al 31/12/16 son 12 meses… lo hago restando mese y me salen 11:
    Ejemplo: en celda A1 pongo 01/01/16 y en celda B1 31/12/16, en la C1 hago la formula siguiente =MES(B1)-MES(A1) = ME TENDRIA QUE SALIR 12 MESES, pero me salen 11.
    Alguien me puede ayudar??
    Gracias,

    • Matias dice:

      Se que es algo tarde, pero la lógica dice que en tu forumla todavía falta un día para que sean 12 meses Entre el 01/01/16 y el 01/01/17 si hay 12 meses 😉

  9. Cecilia dice:

    Buenas tardes,

    me he descargado una hoja de cálculo de internet la cuál me permite tener un seguimiento de mis gastos e ingresos. El problema es que existen dos filas las cuales se llaman 1.Consulta gastos e ingresos (introduzca la fecha inicial) y
    2.Consulta gastos e ingresos (introduzca la fecha fecha final) y al poner una fecha no me realiza ninguna operación puesto que la casilla carece de fórmula.
    ¿Alguien me podría decir la formula para que cuando meta una fecha de inicio y una de fin me calcule cuales han sido los ingresos y los gastos de manera individual teniendo en cuenta ese periodo de tiempo?

    Muchas gracias y saludos.

  10. ivan dice:

    hola,
    Como hago para contar el numero de clientes que compraron en una tienda de panes en un intervalo de tiempo. Por ej. Juan compro 2 panes el 1.1.16, Carlos compro 4 panes el 15.1.16, Pepe compro 2 panes el 12.1.16, Juan compro nuevamente pero esta vez 4 panes el dia 12.1.16. En Total compraron 3 clientes diferente en el mes de enero del 2016 panes. En la siguiente celda en total de panes que vendieron el mes de enero osea 12 panes
    Muchas gracias de antemano por la ayuda.

  11. LUIS E GASTELUM dice:

    la formula que escriben no funciona:
    =SUMAR.SI(A1:A500;”>=”&FECHA(2011;7;10);B1:B1000)-SUMAR.SI(A1:A500;”>”&FECHA(2011;8;22);B1:B1000)

    creo que está incompleta

  12. Hector dice:

    Hola…
    Que formula debo utilizar si quiero cambiar una fecha de envio de producto si no cumplo con la cantidad necesaria para completar la orden… ejemplo… para el dia 1-Feb-2017 debo enviar 200pcs pero tengo fecha compromiso del 20-Ene-2017… a esto yo tengo un total de 24pcs diarias listas para enviar pero necesito realizar el envio de 200pcs… necesito saber en que fecha podre enviar las 200pcs si no cumplo con la fecha acordada…. gracias!

  13. Juan Carlos Alarcon dice:

    Buena Tarde quiero utilizar la función sumar.si pero no he podido ponerle la condicional así:
    Quiero que me sume unas ventas que sean mayores a $ 1.000.000 pero inferiores a $ 2.000.000 para liquidar una comisión del 15% ¿como lo puedo hacer?.

    Gracias

En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.