Sumar valores dentro de un rango de fechas en Excel

Por

En el anterior documento explicamos cómo sumar valores de una fecha específica; en esta oportunidad explicaremos como sumar valores que se encentran en un rango de fechas, es decir entre una fecha y otra.

Supongamos que necesitamos averiguar cuando suman las facturas emitidas entre el 10 de julio de 2011 y el 22 de agosto de 2011. Podríamos utilizar un filtro, pero tal vez sea más cómoda una sencilla fórmula.

Al igual que en el supuesto del documento anterior, supongamos que la fecha de las facturas están en la columna A desde la fila 1 hasta la 1.000 y que el valor de la facturas está en la columna B desde la fila 1 hasta la 1.000.

Como se trata de una suma condicionada a un rango de fechas, utilizamos la fórmula SUMAR.SI de la siguiente forma de acuerdo a nuestro supuesto:

=SUMAR.SI(A1:A500;">="&FECHA(2011;7;10);B1:B1000)-SUMAR.SI(A1:A500;">"&FECHA(2011;8;22);B1:B1000)

Esta fórmula está compuesta por dos partes. La primera parte suma los valores iguales o superiores a una fecha (la inferior). La segunda parte suma los valores superiores a otra fecha (la superior). La sumatoria de la segunda parte se resta a la sumatoria de la primera parte.

Explicación: Si tengo un rango de 1 a 100 y quiero saber cuánto hay de 15 a 30, una de las soluciones es sumar lo que hay entre 15 y 100 y luego restar lo que hay entre 31 y 100. De esta forma me queda únicamente lo que hay entre 15 y 30. Es exactamente lo que hace la fórmula de arriba.

No sobra aclarar que en la primera parte de la formula se indica la fecha límite inferior y en la segunda la fecha límite superior.

Contenido relacionado:
Gerencie.com en su correo.

Suscríbase y nosotros colocaremos en su bandeja de entrada la mejor información que generamos diariamente.


Déjenos su opinión

Una opinión
  1. Juan Carlos Alarcon Dice:

    Buena Tarde quiero utilizar la función sumar.si pero no he podido ponerle la condicional así:
    Quiero que me sume unas ventas que sean mayores a $ 1.000.000 pero inferiores a $ 2.000.000 para liquidar una comisión del 15% ¿como lo puedo hacer?.

    Gracias

    Responder
En Gerencie.com está permitido opinar, criticar, discutir, controvertir, disentir, etc., pero debe hacerlo con respeto, sin insultar y sin ofender a otros.

Información legal aplicable para Colombia.