Fórmulas en Excel para condicionar valores

En Excel existen distintas funciones y fórmulas para condicionar valores dependiendo de las necesidades del usuario. En este artículo vamos a exponer las principales.

Función SI.

La función SI es la más básica y sencilla y que sirve para la mayoría de operaciones cotidianas en las que necesitamos definir alguna condición para efectuar un cálculo.

Por ejemplo, cuando necesitamos aplicar una comisión cuando las ventas del mes superan un determinado monto. Tendríamos algo así:

=A1 * SI(A1<1000; 0%; SI(A1<=5000; 2%; SI(A1<=10000; 4%; 7%)))

Se tiene un rango de ventas con distintos porcentajes según la cantidad vendida, de modo que, si las ventas superan un determinado monto, se aplica un porcentaje, y se superan otro monto diferente, se aplica otro porcentaje.

De esta forma se evalúa si cumple una condición, y si la cumple se hace un cálculo, y si no la cumple, no se hace el cálculo o se hace uno distinto.

Función SUMAR.SI

Esta función permite sumar valores de un rango cuando se cumple una condición.

Supongamos la siguiente tabla de ventas en una semana cualquiera:

A B
        1.450.000 Pedro
           820.000 Juan
           450.000 Carlos
           960.000 Pedro
        1.300.000 Carlos
           865.000 Sandra
        1.235.000 Camila
           826.000 Pedro
        1.378.000 Juan
        1.080.000 Sandra

Requerimos sumar todas las ventas que realizó Pedro, para lo cual utilizamos las siguiente fórmula:

=SUMAR.SI(B1:B10;"Pedro";A1:A10)

La condición para sumar es que los valores del rango A1:A10 correspondan a Pedro, de modo que sólo se sumas las ventas realizadas por pedro.

Función CONTAR.SI

La función CONTAR.SI cuenta siempre que se cumpla una condición, lo que permite saber cuántos datos o valores hay un rango que cumplan determinado criterio.

Supongamos una tabla con los ingreso de cada mes del año:

A B
 Enero         27.600.000
 Febrero         24.800.000
 Marzo         27.900.000
 Abril         11.700.000
 Mayo         27.300.000
 Junio           5.300.000
 Julio         25.700.000
 Agosto         16.600.000
 Septiembre         23.200.000
 Octubre         21.700.000
 Noviembre         25.800.000
 Diciembre           5.900.000

Ahora necesitamos conocer cuántos meses tuvieron venta superiores a $10.000.000. La fórmula es la siguiente:

=CONTAR.SI(B2:B7; ">1000000")

Excel busca los meses que tengan ventas superiores al valor indicado y cuenta cuántos meses cumplen dicha condición.

Función SI y función Y, doble condición.

Es posible hacer que Excel evalúe 2 condiciones y haga los cálculos pertinente.

Por ejemplo, supongamos una tabla con las notas de los estudiantes, y para aprobar el curso las dos notas deben ser superiores a 70 puntos.

A B C D
Estudiante Parcial 1 Parcial 2 Resultado
Estudiante 1 75 85 Aprobado
Estudiante 2 90 69 Reprobado
Estudiante 3 80 82 Aprobado
Estudiante 4 65 78 Reprobado

Para determinar si el estudiante ha aprobado o reprobado se debe evaluar que en los 2 exámenes se hayan cumplido los objetivos. Si en uno de ellos no se cumple la condición, que es ser superior a 70, se reprueba, lo que se hace con la siguiente fórmula:

=SI(Y(B2>=70; C2>=70); "Aprobado"; "Reprobado")

Hay dos condiciones que se unen con EL operador Y (AND), de modo que las dos se deben cumplir para ser aprobado, de lo contrario será reprobado.

También se puede definir para que sólo deba cumplir una de las condiciones, que se hace con el operador lógico O (OR), así:

=SI(O(B2>=70; C2>=70); "Aprobado"; "Reprobado")

Será aprobado si cualquiera de los 2 exámenes es superior a 70. Si ninguno alcana ese valor será reprobado.

Evaluar varias condiciones para hacer cálculos.

Se puede dar el caso de operaciones que requiere cumplir más de 2 condiciones, como por ejemplo cuando se quiere determinar la obligación o no de declarar renta, que se requiere cumplir con 5 condiciones:

A B C
  Concepto  Valor Tope en Uvt
Ingresos 2.000  1.400
Patrimonio    200  4.500
Consumos con tarjeta    300  1.400
Compras 1.200  1.400
Consignaciones    400  1.400

Para evaluar las 5 condiciones se utiliza la siguiente fórmula:

=SI(Y(B2 < C2; B3 < C3; B4 < C4; B5 < C5; B6 < C6); "No Declarante"; "Declarante")

Se debe hacer una valoración de cada valor de la columna B que será comparado con la columna C para determinar si lo supera o no.

Se requiere que todos los valores se cumplan, y por eso se incluye el operador lógico Y.

Recomendados.

Compártalo en Facebook Compártalo en Twitter Compártalo en Whatsapp
Deje su opinión o su pregunta.

Regístrese para informarle cuando se responda su pregunta.

Este sitio web utiliza cookies propias y de terceros para ofrecer un mejor servicio. Al seguir navegando acepta su uso.